summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorMichael Adam <obnox@samba.org>2008-02-19 16:35:55 +0100
committerMichael Adam <obnox@samba.org>2008-02-19 17:39:40 +0100
commit5073bd13493fbfb158857ca0807424e631a29872 (patch)
treec436219672309bc0509363a0b70823a634db747c /source3/configure.in
parent90ea8ae9b1ed3b7ed1c93076517e026e629ea1aa (diff)
downloadsamba-5073bd13493fbfb158857ca0807424e631a29872.tar.gz
samba-5073bd13493fbfb158857ca0807424e631a29872.tar.bz2
samba-5073bd13493fbfb158857ca0807424e631a29872.zip
Move the --enable-debug check up above all compiler checks.
Michael (This used to be commit fb74f8dd6a612db0d79b091dd9972bb3204818fb)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in18
1 files changed, 9 insertions, 9 deletions
diff --git a/source3/configure.in b/source3/configure.in
index e9b93eeb4b..4a9dc0c139 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -267,6 +267,15 @@ AC_SUBST(cachedir)
AC_SUBST(rootsbindir)
AC_SUBST(pammodulesdir)
+## check for --enable-debug first before checking CFLAGS before
+## so that we don't mix -O and -g
+debug=no
+AC_ARG_ENABLE(debug,
+[AS_HELP_STRING([--enable-debug], [Turn on compiler debugging information (default=no)])],
+ [if eval "test x$enable_debug = xyes"; then
+ debug=yes
+ fi])
+
AC_ARG_WITH(cfenc,
[AS_HELP_STRING([--with-cfenc=HEADERDIR], [Use internal CoreFoundation encoding API for optimization (Mac OS X/Darwin only)])],
[
@@ -408,15 +417,6 @@ AC_SUBST(EXTRA_ALL_TARGETS)
AC_SUBST(CONFIG_LIBS)
AC_SUBST(NSCD_LIBS)
-## check for --enable-debug first before checking CFLAGS before
-## so that we don't mix -O and -g
-debug=no
-AC_ARG_ENABLE(debug,
-[AS_HELP_STRING([--enable-debug], [Turn on compiler debugging information (default=no)])],
- [if eval "test x$enable_debug = xyes"; then
- debug=yes
- fi])
-
# compile with optimization and without debugging by default, but
# allow people to set their own preference.
# do this here since AC_CACHE_CHECK apparently sets the CFLAGS to "-g -O2"