summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorVolker Lendecke <vlendec@samba.org>2007-08-27 11:41:05 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 12:30:14 -0500
commit5b9ecb5ae3fbbe10260312608f1a175e683347fe (patch)
treec410824b7e3f5bb4035da6c21c7ac171840a80df /source3/configure.in
parent3aed02989f0366c48ce2fa41186ad53caadc26d3 (diff)
downloadsamba-5b9ecb5ae3fbbe10260312608f1a175e683347fe.tar.gz
samba-5b9ecb5ae3fbbe10260312608f1a175e683347fe.tar.bz2
samba-5b9ecb5ae3fbbe10260312608f1a175e683347fe.zip
r24701: Fix the swat build
Swat has not been built by default for a while, so I did not notice that the _ macro is actually used. Re-add the lang_msg_rotate function, this time only to swat so that this is the only binary that has to take the 16k penalty. (This used to be commit 191e1ef840c293f8575cc0a3f3ffba2080431fae)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in14
1 files changed, 8 insertions, 6 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 0d0fdb1394..6997106ffb 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -354,21 +354,23 @@ AC_LIBREPLACE_CC_CHECKS
m4_include(lib/socket_wrapper/config.m4)
+SWAT_SBIN_TARGETS='bin/swat$(EXEEXT)'
+SWAT_INSTALL_TARGETS=installswat
AC_ARG_ENABLE(swat,
[ --enable-swat Build the SWAT tool (default=yes)],
[
case "$enable_swat" in
- no) ;;
- *)
- SWAT_SBIN_TARGETS='bin/swat$(EXEEXT)'
- SWAT_INSTALL_TARGETS=installswat
+ no)
+ SWAT_SBIN_TARGETS=''
+ SWAT_INSTALL_TARGETS=''
;;
esac
- AC_SUBST(SWAT_SBIN_TARGETS)
- AC_SUBST(SWAT_INSTALL_TARGETS)
])
+AC_SUBST(SWAT_SBIN_TARGETS)
+AC_SUBST(SWAT_INSTALL_TARGETS)
+
#################################################
# set prefix for 'make test'
selftest_prefix="./"