summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Bartlett <abartlet@samba.org>2002-03-23 08:28:19 +0000
committerAndrew Bartlett <abartlet@samba.org>2002-03-23 08:28:19 +0000
commit657a24f476c90e0ffa8171f78b35a449171f54e1 (patch)
tree35da20fdef21bef1d7c1c7087846db078e088d31 /source3/configure.in
parent26588248cda26c6c8216a9b49008cb6d0e7f3bce (diff)
downloadsamba-657a24f476c90e0ffa8171f78b35a449171f54e1.tar.gz
samba-657a24f476c90e0ffa8171f78b35a449171f54e1.tar.bz2
samba-657a24f476c90e0ffa8171f78b35a449171f54e1.zip
Various winbind updates:
- pam_winbind updates from vance, fixing a typo and making some the options work properly. - Extra parinoia in the winbind connection loop - Allow pam_winbind to compile on HP-UX (Don Mcall, more work to do). - Fix up configure.in to use the same method for building the test .so as the Makefile uses. Andrew Bartlett (This used to be commit 8e705dd9215b1cb3f44d6348094679d7dc6a7fbd)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in7
1 files changed, 4 insertions, 3 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 3610b37b25..59df6e8099 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -763,8 +763,9 @@ case "$host_os" in
SHLIBEXT="sl"
# Use special PIC flags for the native HP-UX compiler.
if test $ac_cv_prog_cc_Ae = yes; then
- #BLDSHARED="true"
- LDSHFLAGS="-b -z +h \$@"
+ SHLD="/usr/bin/ld"
+ BLDSHARED="true"
+ LDSHFLAGS="-B symbolic -b -z +h \$@"
PICFLAG="+z"
fi
DYNEXP="-Wl,-E"
@@ -823,7 +824,7 @@ AC_CACHE_CHECK([whether building shared libraries actually works],
ac_cv_shlib_works=no
# try building a trivial shared library
$CC $CPPFLAGS $CFLAGS $PICFLAG -c -o shlib.po ${srcdir-.}/tests/shlib.c &&
- $CC $CPPFLAGS $CFLAGS $LDSHFLAGS -o shlib.so shlib.po &&
+ $SHLD $CPPFLAGS $CFLAGS $LDSHFLAGS -o shlib.so shlib.po &&
ac_cv_shlib_works=yes
rm -f shlib.so shlib.po
])