summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Tridgell <tridge@samba.org>2002-01-07 11:42:12 +0000
committerAndrew Tridgell <tridge@samba.org>2002-01-07 11:42:12 +0000
commit6c14b8c387cb66188c710d2b53cf1e4ccd159be5 (patch)
treefd9adb21362f4df5aebf0e06f97f8e3af44ddcf6 /source3/configure.in
parent17729f5dc5aa4a19fd2cdfed12f86da3e9d07ecc (diff)
downloadsamba-6c14b8c387cb66188c710d2b53cf1e4ccd159be5.tar.gz
samba-6c14b8c387cb66188c710d2b53cf1e4ccd159be5.tar.bz2
samba-6c14b8c387cb66188c710d2b53cf1e4ccd159be5.zip
- use CFLAGS when linking shared libs (for things like -64 on irix)
- don't attempt to build winbindd if we can't do shared libs (This used to be commit c98158f3f818118fb13cc7ae6f45634204343b46)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 46b82af4b2..2340a1129c 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -782,7 +782,7 @@ AC_CACHE_CHECK([whether building shared libraries actually works],
ac_cv_shlib_works=no
# try building a trivial shared library
$CC $CPPFLAGS $CFLAGS $PICFLAG -c -o shlib.po ${srcdir-.}/tests/shlib.c &&
- $CC $LDSHFLAGS -o shlib.so shlib.po &&
+ $CC $CPPFLAGS $CFLAGS $LDSHFLAGS -o shlib.so shlib.po &&
ac_cv_shlib_works=yes
rm -f shlib.so shlib.po
])
@@ -2538,7 +2538,7 @@ fi
# Display test results
-if test x"$HAVE_WINBIND" = x"yes"; then
+if test x"$HAVE_WINBIND" = x"yes" && test x"$BLDSHARED" = x"true"; then
AC_MSG_RESULT(yes)