summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Bartlett <abartlet@samba.org>2002-11-13 04:14:21 +0000
committerAndrew Bartlett <abartlet@samba.org>2002-11-13 04:14:21 +0000
commit6de53c67564f298aaf50426de3e9199a04c4885e (patch)
treebfeb14dad48ba59d65bb8b0d932e4ec67caf3deb /source3/configure.in
parent2bd37f8565363f53ba8ba0d68cd47429ccaa2991 (diff)
downloadsamba-6de53c67564f298aaf50426de3e9199a04c4885e.tar.gz
samba-6de53c67564f298aaf50426de3e9199a04c4885e.tar.bz2
samba-6de53c67564f298aaf50426de3e9199a04c4885e.zip
Undo the new --enable-developer flags that caused breakage on gcc != 3.2, and
rerun autoconf (This used to be commit 6da20cd7638b5e36af080a4b8ae8880035fe684b)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 3f36cb87f1..8e15da6fac 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -161,12 +161,12 @@ AC_ARG_ENABLE(debug,
AC_ARG_ENABLE(developer, [ --enable-developer Turn on developer warnings and debugging (default=no)],
[if eval "test x$enable_developer = xyes"; then
- CFLAGS="${CFLAGS} -g -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual -Wcast-align -Wfloat-equal -Wbad-function-cast -Wmissing-prototypes -Wmissing-declarations -Wmissing-format-attribute -Wdisabled-optimization -DDEBUG_PASSWORD -DDEVELOPER"
+ CFLAGS="${CFLAGS} -g -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual -Wcast-align -DDEBUG_PASSWORD -DDEVELOPER"
fi])
AC_ARG_ENABLE(krb5developer, [ --enable-krb5developer Turn on developer warnings and debugging, except -Wstrict-prototypes (default=no)],
[if eval "test x$enable_krb5developer = xyes"; then
- CFLAGS="${CFLAGS} -g -Wall -Wshadow -Wpointer-arith -Wcast-qual -Wcast-align -Wfloat-equal -Wbad-function-cast -Wmissing-prototypes -Wmissing-declarations -Wmissing-format-attribute -Wdisabled-optimization -DDEBUG_PASSWORD -DDEVELOPER"
+ CFLAGS="${CFLAGS} -g -Wall -Wshadow -Wpointer-arith -Wcast-qual -Wcast-align -DDEBUG_PASSWORD -DDEVELOPER"
fi])
AC_ARG_ENABLE(dmalloc, [ --enable-dmalloc Enable heap debugging [default=no]])