summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorGerald Carter <jerry@samba.org>2003-05-20 18:26:06 +0000
committerGerald Carter <jerry@samba.org>2003-05-20 18:26:06 +0000
commit6eaf8a377562b2bebdf224f94cd586d2ebc5e987 (patch)
treea0c1121f120b52254f342c917e496e4adf5791a9 /source3/configure.in
parent0de9034b4fb91897702c06d12e2dc5054e45cd4d (diff)
downloadsamba-6eaf8a377562b2bebdf224f94cd586d2ebc5e987.tar.gz
samba-6eaf8a377562b2bebdf224f94cd586d2ebc5e987.tar.bz2
samba-6eaf8a377562b2bebdf224f94cd586d2ebc5e987.zip
wrap pdb_[nisplussam|xml|mysql] in --with-expsam option & some formatting fixes
(This used to be commit 014350196df287beae212e99d22dc63ecbe7d36e)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in61
1 files changed, 42 insertions, 19 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 3c2e1f4292..6fc03ad151 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -285,7 +285,7 @@ DYNEXP=
dnl Add modules that have to be built by default here
dnl These have to be built static:
-default_static_modules="pdb_smbpasswd pdb_tdbsam pdb_unix rpc_lsa rpc_samr rpc_reg rpc_wks rpc_net rpc_dfs rpc_srv rpc_spoolss auth_rhosts auth_sam auth_unix auth_winbind auth_server auth_domain auth_builtin idmap_winbind"
+default_static_modules="pdb_smbpasswd pdb_tdbsam pdb_guest rpc_lsa rpc_samr rpc_reg rpc_wks rpc_net rpc_dfs rpc_srv rpc_spoolss auth_rhosts auth_sam auth_unix auth_winbind auth_server auth_domain auth_builtin idmap_winbind"
dnl These are preferably build shared, and static if dlopen() is not available
default_shared_modules="vfs_recycle vfs_audit vfs_extd_audit vfs_netatalk vfs_fake_perms"
@@ -723,7 +723,7 @@ test "${with_readline+set}" != "set" && with_readline=yes
# test for where we get readline() from
AC_MSG_CHECKING(whether to use readline)
AC_ARG_WITH(readline,
-[ --with-readline[=DIR] Look for readline include/libs in DIR (default=auto) ],
+[ --with-readline[=DIR] Look for readline include/libs in DIR (default=auto) ],
[ case "$with_readline" in
yes)
AC_MSG_RESULT(yes)
@@ -2092,7 +2092,7 @@ with_ads_support=yes
AC_MSG_CHECKING([whether to use Active Directory])
AC_ARG_WITH(ads,
-[ --with-ads Active Directory support (default yes)],
+[ --with-ads Active Directory support (default yes)],
[ case "$withval" in
no)
with_ads_support=no
@@ -2291,7 +2291,7 @@ with_ldap_support=yes
AC_MSG_CHECKING([whether to use LDAP])
AC_ARG_WITH(ldap,
-[ --with-ldap LDAP support (default yes)],
+[ --with-ldap LDAP support (default yes)],
[ case "$withval" in
no)
with_ldap_support=no
@@ -2347,14 +2347,27 @@ if test x"$with_ads_support" = x"yes"; then
fi
########################################################
-# Compile with MySQL support?
-AM_PATH_MYSQL([0.11.0],[default_shared_modules="$default_shared_modules pdb_mysql"],[])
-CFLAGS="$CFLAGS $MYSQL_CFLAGS"
-
-########################################################
-# Compile with XML support?
-AM_PATH_XML2([2.0.0],[default_shared_modules="$default_shared_modules pdb_xml"],[])
-CFLAGS="$CFLAGS $XML_CFLAGS"
+# Compile experimental passdb backends?
+# (pdb_xml, pdb_mysql)
+build_expsam=0
+AC_MSG_CHECKING(whether to build experimental passdb libraries)
+AC_ARG_WITH(expsam,
+[ --with-expsam Include experimental passdb libraries (default=no)],
+[ case "$withval" in
+ yes)
+ AC_MSG_RESULT(yes)
+ build_expsam=1
+ AM_PATH_XML2([2.0.0],[default_shared_modules="$default_shared_modules pdb_xml"],[])
+ CFLAGS="$CFLAGS $XML_CFLAGS"
+ AM_PATH_MYSQL([0.11.0],[default_shared_modules="$default_shared_modules pdb_mysql"],[])
+ CFLAGS="$CFLAGS $MYSQL_CFLAGS"
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+ esac ],
+ AC_MSG_RESULT(no)
+)
#################################################
# check for automount support
@@ -2426,7 +2439,7 @@ AC_CHECK_LIB(pam, pam_get_data, [AC_DEFINE(HAVE_LIBPAM,1,[Whether libpam is avai
# check for pam_smbpass support
AC_MSG_CHECKING(whether to use pam_smbpass)
AC_ARG_WITH(pam_smbpass,
-[ --with-pam_smbpass Build a PAM module to allow other applications to use our smbpasswd file (default=no)],
+[ --with-pam_smbpass Build PAM module for authenticating against passdb backends (default=no)],
[ case "$withval" in
yes)
AC_MSG_RESULT(yes)
@@ -2483,7 +2496,7 @@ fi
# check for a LDAP password database configuration backwards compatibility
AC_MSG_CHECKING(whether to use LDAP SAM 2.2 compatible configuration)
AC_ARG_WITH(ldapsam,
-[ --with-ldapsam Include LDAP SAM 2.2 compatible configuration (default=no)],
+[ --with-ldapsam Include LDAP SAM 2.2 compatible configuration (default=no)],
[ case "$withval" in
yes)
AC_MSG_RESULT(yes)
@@ -2503,7 +2516,7 @@ AC_DEFINE(WITH_IDMAP,1, [Include IDMAP support])
AC_MSG_CHECKING(whether to use IDMAP only for [ug]id mapping)
AC_ARG_WITH(idmap,
-[ --with-idmap Include experimental IDMAP support (default=yes)],
+[ --with-idmap Include experimental IDMAP support (default=yes)],
[ case "$withval" in
yes)
AC_MSG_RESULT(yes)
@@ -3259,7 +3272,7 @@ samba_cv_HAVE_ACL_GET_PERM_NP=yes,samba_cv_HAVE_ACL_GET_PERM_NP=no)
with_sendfile_support=yes
AC_MSG_CHECKING(whether to check to support sendfile)
AC_ARG_WITH(sendfile-support,
-[ --with-sendfile-support Check for sendfile support (default=yes)],
+[ --with-sendfile-support Check for sendfile support (default=yes)],
[ case "$withval" in
yes)
@@ -3688,15 +3701,25 @@ AC_ARG_WITH(shared-modules,
done
fi ])
-SMB_MODULE(pdb_xml, passdb/pdb_xml.o, "bin/xml.$SHLIBEXT", PDB,
+###########################################################################
+## experimental pdb_modules
+
+if test $build_expsam; then
+
+ SMB_MODULE(pdb_xml, passdb/pdb_xml.o, "bin/xml.$SHLIBEXT", PDB,
[ PASSDBLIBS="$PASSDBLIBS $XML_LIBS" ] )
-SMB_MODULE(pdb_mysql, passdb/pdb_mysql.o, "bin/mysql.$SHLIBEXT", PDB,
+ SMB_MODULE(pdb_mysql, passdb/pdb_mysql.o, "bin/mysql.$SHLIBEXT", PDB,
[ PASSDBLIBS="$PASSDBLIBS $MYSQL_LIBS" ] )
+ SMB_MODULE(pdb_nisplussam, passdb/pdb_nisplus.o, "bin/nisplussam.$SHLIBEXT", PDB)
+fi
+
+## end of experiementlal pdb_modules
+###########################################################################
+
SMB_MODULE(pdb_ldap, passdb/pdb_ldap.o, "bin/ldapsam.$SHLIBEXT", PDB,
[ PASSDBLIBS="$PASSDBLIBS $LDAP_LIBS" ] )
SMB_MODULE(pdb_smbpasswd, passdb/pdb_smbpasswd.o, "bin/smbpasswd.$SHLIBEXT", PDB)
SMB_MODULE(pdb_tdbsam, passdb/pdb_tdb.o, "bin/tdbsam.$SHLIBEXT", PDB)
-SMB_MODULE(pdb_nisplussam, passdb/pdb_nisplus.o, "bin/nisplussam.$SHLIBEXT", PDB)
SMB_MODULE(pdb_guest, passdb/pdb_guest.o, "bin/guest.$SHLIBEXT", PDB)
SMB_SUBSYSTEM(PDB)