summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorBrad Smith <brad@comstyle.com>2012-02-25 09:28:43 +0100
committerVolker Lendecke <vl@samba.org>2012-02-25 09:42:24 +0100
commit71a6d334321d42fd0f02646d1649405ccf197c00 (patch)
treef05a45ad836c4f045e89fcb2ad457d21c392562d /source3/configure.in
parent0fbefbcb54eb0610d4cbd3579914f884d0ae6fa5 (diff)
downloadsamba-71a6d334321d42fd0f02646d1649405ccf197c00.tar.gz
samba-71a6d334321d42fd0f02646d1649405ccf197c00.tar.bz2
samba-71a6d334321d42fd0f02646d1649405ccf197c00.zip
s3: Fix bug 8777, sys_statvfs() wrapper support for OpenBSD/FreeBSD/DragonFly
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in10
1 files changed, 9 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 7b90c8f075..dc47f13ff6 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -6838,13 +6838,21 @@ CFLAGS=$CFLAGS_SAVE
# Start
AC_CHECK_FUNC(getmntent)
-AC_CHECK_HEADERS(sys/statfs.h)
+AC_CHECK_HEADERS(sys/param.h sys/statfs.h sys/mount.h)
AC_MSG_CHECKING([vfs_fileid: checking for statfs() and struct statfs.f_fsid)])
AC_CACHE_VAL(vfsfileid_cv_statfs,[
AC_TRY_RUN([
#include <sys/types.h>
+ #ifdef HAVE_SYS_PARAM_H
+ #include <sys/param.h>
+ #endif
+ #ifdef HAVE_SYS_MOUNT_H
+ #include <sys/mount.h>
+ #endif
+ #ifdef HAVE_SYS_STATFS_H
#include <sys/statfs.h>
+ #endif
int main(void)
{
struct statfs fsd;