summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJames Peach <jpeach@samba.org>2007-04-20 16:07:16 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 12:19:32 -0500
commit772ffe76fe241e1b4ec28c803977178076ce7357 (patch)
tree7f8045709f2ff3377e9b8b03e2887406a343f9f6 /source3/configure.in
parent956a5ce7d52f9f7d14c39e4086970a36b5871cd3 (diff)
downloadsamba-772ffe76fe241e1b4ec28c803977178076ce7357.tar.gz
samba-772ffe76fe241e1b4ec28c803977178076ce7357.tar.bz2
samba-772ffe76fe241e1b4ec28c803977178076ce7357.zip
r22413: Simplify the build rules for plugin modules. Add support for per-platform
exports files. Fix the shared library build pf pdb_ldap. (This used to be commit b04dee02d1965a1bf6eba39e809f0c9b33fbfcda)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index e652222d1b..1e9fca76f5 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -259,6 +259,7 @@ dnl Unique-to-Samba variables we'll be playing with.
AC_SUBST(SAMBA_CPPFLAGS)
AC_SUBST(SHELL)
AC_SUBST(LDSHFLAGS)
+AC_SUBST(MODULE_EXPORTS)
AC_SUBST(SONAMEFLAG)
AC_SUBST(SHLD)
AC_SUBST(HOST_OS)
@@ -1672,11 +1673,13 @@ BLDSHARED="false"
# these are the defaults, good for lots of systems
HOST_OS="$host_os"
LDSHFLAGS="-shared"
+MODULE_EXPORTS=""
SONAMEFLAG="#"
SHLD="\${CC} \${CFLAGS}"
PICFLAG="${PIE_CFLAGS}"
SHLIBEXT="so"
+
# this bit needs to be modified for each OS that supports share libs
# You need to specify how to create a shared library and
# how to compile C code to produce PIC object files
@@ -1850,6 +1853,7 @@ case "$host_os" in
*darwin*) AC_DEFINE(DARWINOS,1,[Whether the host os is Darwin/MacOSX])
BLDSHARED="true"
LDSHFLAGS="-bundle -flat_namespace -undefined suppress"
+ MODULE_EXPORTS="-exported_symbols_list \$(srcdir)/modules/exports.darwin"
SHLIBEXT="dylib"
# Since gcc doesn't fail on unrecognised options, the
# PIE test incorrectly succeeds. Darwin gcc does not