summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2000-12-06 00:05:15 +0000
committerJeremy Allison <jra@samba.org>2000-12-06 00:05:15 +0000
commit7e4c4721b4fbfa71ce6712ec5b9f3e8e8a105147 (patch)
tree2df359e8d49573fd79674cbb8cd592ce896a93d0 /source3/configure.in
parent1cd8538b7abf0970082074d7a114bb9d013d00b2 (diff)
downloadsamba-7e4c4721b4fbfa71ce6712ec5b9f3e8e8a105147.tar.gz
samba-7e4c4721b4fbfa71ce6712ec5b9f3e8e8a105147.tar.bz2
samba-7e4c4721b4fbfa71ce6712ec5b9f3e8e8a105147.zip
Changed to sourceforge tdb code. This includes spinlocks (so we now have
a --with-spinlocks option to configure, this does mean the on-disk tdb format has changed, so 2.2alphaX sites will need to re-create their tdb's. The upside is no more tdb fragmentation and a +5% on netbench. Swings and roundabouts.... Jeremy. (This used to be commit 9dea7b7c257db487f8ced7dad3fce92fba03ea91)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in23
1 files changed, 23 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index f7f8b95845..b5d4d881e0 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1902,6 +1902,29 @@ else
echo "no"
fi
+AC_ARG_WITH(spinlocks, [ --with-spinlocks use spin locks instead of fcntl locks ])
+if test "x$with_spinlocks" = "xyes"; then
+ AC_DEFINE(USE_SPINLOCKS)
+
+ case "$host_cpu" in
+ sparc)
+ AC_DEFINE(SPARC_SPINLOCKS)
+ ;;
+
+ i386|i486|i586|i686)
+ AC_DEFINE(INTEL_SPINLOCKS)
+ ;;
+
+ mips)
+ AC_DEFINE(MIPS_SPINLOCKS)
+ ;;
+
+ powerpc)
+ AC_DEFINE(POWERPC_SPINLOCKS)
+ ;;
+ esac
+fi
+
echo "checking configure summary"
AC_TRY_RUN([#include "${srcdir-.}/tests/summary.c"],
echo "configure OK";,