summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAlexander Bokovoy <ab@samba.org>2003-02-15 15:47:32 +0000
committerAlexander Bokovoy <ab@samba.org>2003-02-15 15:47:32 +0000
commit7f6fdf49cb3bac59a0998a0877b1f481a5a461a4 (patch)
tree0d86ee25ae387b111d00a9eae4ebe89c2260182a /source3/configure.in
parent5296e0d1e84269a7a8a1287afd47ae52b5577757 (diff)
downloadsamba-7f6fdf49cb3bac59a0998a0877b1f481a5a461a4.tar.gz
samba-7f6fdf49cb3bac59a0998a0877b1f481a5a461a4.tar.bz2
samba-7f6fdf49cb3bac59a0998a0877b1f481a5a461a4.zip
Add support for krb5-config from recent MIT and Heimdal. And fallback to traditional guessing only if krb5-config was not found.
(This used to be commit ca27334ba0f2ffbe0fd2a18ef5edf644d4e52190)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in17
1 files changed, 16 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index aaa0499531..02111161c3 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2083,6 +2083,21 @@ FOUND_KRB5=no
if test x"$with_ads_support" = x"yes"; then
#################################################
+ # check for krb5-config from recent MIT and Heimdal kerberos 5
+ AC_PATH_PROG(KRB5_CONFIG, krb5-config)
+ AC_MSG_CHECKING(for working krb5-config)
+ if test -x "$KRB5_CONFIG"; then
+ LIBS="$LIBS `$KRB5_CONFIG --libs`"
+ CFLAGS="$CFLAGS `$KRB5_CONFIG --cflags`"
+ CPPFLAGS="$CPPFLAGS `$KRB5_CONFIG --cflags`"
+ FOUND_KRB5=yes
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_RESULT(no. Fallback to previous krb5 detection strategy)
+ fi
+
+ if test x$FOUND_KRB5 = x"no"; then
+ #################################################
# check for location of Kerberos 5 install
AC_MSG_CHECKING(for kerberos 5 install path)
AC_ARG_WITH(krb5,
@@ -2102,7 +2117,7 @@ if test x"$with_ads_support" = x"yes"; then
esac ],
AC_MSG_RESULT(no)
)
-
+ fi
if test x$FOUND_KRB5 = x"no"; then
#################################################