summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorMichael Adam <obnox@samba.org>2008-02-19 16:24:24 +0100
committerMichael Adam <obnox@samba.org>2008-02-19 17:39:40 +0100
commit86e758e24648f39ed547394165390df5e43e027d (patch)
tree25a3b267975f5c718e34a990c1a38b58c026aa57 /source3/configure.in
parentc666d5b3845fa7536a07b45515f2e34575951d07 (diff)
downloadsamba-86e758e24648f39ed547394165390df5e43e027d.tar.gz
samba-86e758e24648f39ed547394165390df5e43e027d.tar.bz2
samba-86e758e24648f39ed547394165390df5e43e027d.zip
configure: move AC_SUBST's of certain directories to the corresponding checks.
Michael (This used to be commit 28c862704c27aaffc858650d0a4f4cc7893bb406)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in30
1 files changed, 15 insertions, 15 deletions
diff --git a/source3/configure.in b/source3/configure.in
index a595ebb83e..2c7ebdd8e6 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -252,6 +252,21 @@ AC_ARG_WITH(mandir,
;;
esac])
+AC_SUBST(configdir)
+AC_SUBST(lockdir)
+AC_SUBST(piddir)
+AC_SUBST(logfilebase)
+AC_SUBST(ctdbdir)
+AC_SUBST(privatedir)
+AC_SUBST(swatdir)
+AC_SUBST(bindir)
+AC_SUBST(sbindir)
+AC_SUBST(codepagedir)
+AC_SUBST(statedir)
+AC_SUBST(cachedir)
+AC_SUBST(rootsbindir)
+AC_SUBST(pammodulesdir)
+
AC_ARG_WITH(cfenc,
[AS_HELP_STRING([--with-cfenc=HEADERDIR], [Use internal CoreFoundation encoding API for optimization (Mac OS X/Darwin only)])],
[
@@ -310,21 +325,6 @@ if test "x${srcdir-.}" != "x."; then
SAMBA_CPPFLAGS=`echo ${SAMBA_CPPFLAGS} | sed -e "s;${srcdir};\$\(srcdir\);g"`
fi
-AC_SUBST(configdir)
-AC_SUBST(lockdir)
-AC_SUBST(piddir)
-AC_SUBST(logfilebase)
-AC_SUBST(ctdbdir)
-AC_SUBST(privatedir)
-AC_SUBST(swatdir)
-AC_SUBST(bindir)
-AC_SUBST(sbindir)
-AC_SUBST(codepagedir)
-AC_SUBST(statedir)
-AC_SUBST(cachedir)
-AC_SUBST(rootsbindir)
-AC_SUBST(pammodulesdir)
-
dnl Unique-to-Samba variables we'll be playing with.
AC_SUBST(SAMBA_CPPFLAGS)
AC_SUBST(SHELL)