summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJames Peach <jpeach@samba.org>2006-06-09 01:02:54 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 11:17:20 -0500
commit8882d08b6ba90c45f8107eef3d28614eb643dfb9 (patch)
tree132d98a983eb0cffb53cbc6adc5c3cfcbfb05366 /source3/configure.in
parentb7eaff26dc71a4ecf54ab07674c9b4c4b0273544 (diff)
downloadsamba-8882d08b6ba90c45f8107eef3d28614eb643dfb9.tar.gz
samba-8882d08b6ba90c45f8107eef3d28614eb643dfb9.tar.bz2
samba-8882d08b6ba90c45f8107eef3d28614eb643dfb9.zip
r16111: Patch from Björn JACKE <samba@j3e.de>.
This fixes a problem where the clock definition for clock_gettime() is present at compile time, but is not available on the running system. In this case, we fall back to less-preferred clocks until we find one that we can use. (This used to be commit fc6ed6a1aa2225ccde04c4ecaf0777dc0de4f1cb)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in9
1 files changed, 7 insertions, 2 deletions
diff --git a/source3/configure.in b/source3/configure.in
index f8eba2349f..799441ed95 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2053,8 +2053,13 @@ if test x"$samba_cv_WITH_PROFILE" = x"yes"; then
[
SMB_IS_LIBPTHREAD_LINKED(
[ SMB_REMOVELIB(rt) ],
- [ AC_DEFINE(HAVE_CLOCK_GETTIME, 1,
- [Whether clock_gettime is available]) ])
+ [
+ AC_DEFINE(HAVE_CLOCK_GETTIME, 1,
+ [Whether clock_gettime is available])
+ SMB_CHECK_CLOCK_ID(CLOCK_MONOTONIC)
+ SMB_CHECK_CLOCK_ID(CLOCK_PROCESS_CPUTIME_ID)
+ SMB_CHECK_CLOCK_ID(CLOCK_REALTIME)
+ ])
])
fi