summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorBrad Smith <brad@comstyle.com>2012-03-02 01:34:16 +0100
committerVolker Lendecke <vl@samba.org>2012-03-02 10:30:07 +0100
commit8bdc2890999c850519913be0e829e9ced979ac2f (patch)
tree41657f95b3e2d4a7ad487a248dcf7c3d0e19f9d8 /source3/configure.in
parentdcb1cd293364b5269aaf3b0ac0e475aeb18e9bab (diff)
downloadsamba-8bdc2890999c850519913be0e829e9ced979ac2f.tar.gz
samba-8bdc2890999c850519913be0e829e9ced979ac2f.tar.bz2
samba-8bdc2890999c850519913be0e829e9ced979ac2f.zip
s3: Further fix for bug 8777
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in41
1 files changed, 32 insertions, 9 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 6c7c3b0969..6269b4c6d9 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -6834,25 +6834,48 @@ fi
CFLAGS=$CFLAGS_SAVE
-# Checks for the vfs_fileid module
+# Checks for *BSD bsd_statvfs() function
# Start
-AC_CHECK_FUNC(getmntent)
-
-AC_CHECK_HEADERS(sys/param.h sys/statfs.h sys/mount.h)
+AC_CHECK_HEADERS(sys/param.h sys/mount.h)
-AC_MSG_CHECKING([vfs_fileid: checking for statfs() and struct statfs.f_fsid)])
-AC_CACHE_VAL(vfsfileid_cv_statfs,[
+AC_MSG_CHECKING([bsd_statvfs: checking for statfs() and struct statfs.bsize])
+AC_CACHE_VAL(bsdstatvfs_cv_statfs,[
AC_TRY_RUN([
- #include <sys/types.h>
#ifdef HAVE_SYS_PARAM_H
#include <sys/param.h>
#endif
#ifdef HAVE_SYS_MOUNT_H
#include <sys/mount.h>
#endif
- #ifdef HAVE_SYS_STATFS_H
+ int main (void)
+ {
+ struct statfs fsd;
+ fsd.f_bsize = 0;
+ exit (statfs (".", &fsd));
+ }],
+ bsdstatvfs_cv_statfs=yes,
+ bsdstatvfs_cv_statfs=no,
+ bsdstatvfs_cv_statfs=no)])
+AC_MSG_RESULT($bsdstatvfs_cv_statfs)
+
+if test $bsdstatvfs_cv_statfs = yes; then
+ AC_DEFINE(BSD_STATVFS_BSIZE,1,[Whether statfs exists and struct statfs has bsize property])
+fi
+
+# End
+# Checks for *BSD sys_statvfs() function
+
+# Checks for the vfs_fileid module
+# Start
+AC_CHECK_FUNC(getmntent)
+
+AC_CHECK_HEADERS(sys/statfs.h)
+
+AC_MSG_CHECKING([vfs_fileid: checking for statfs() and struct statfs.f_fsid])
+AC_CACHE_VAL(vfsfileid_cv_statfs,[
+ AC_TRY_RUN([
+ #include <sys/types.h>
#include <sys/statfs.h>
- #endif
int main(void)
{
struct statfs fsd;