summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>1998-11-18 22:04:24 +0000
committerJeremy Allison <jra@samba.org>1998-11-18 22:04:24 +0000
commit9579b9823707b9acadfd7bf24d1c540eacf53fc0 (patch)
tree41ddb7a17316ec66ea47bdc58e9b562fbf157222 /source3/configure.in
parentbb9622bfa6bbbe74a6e4c032cf81501bcbff999d (diff)
downloadsamba-9579b9823707b9acadfd7bf24d1c540eacf53fc0.tar.gz
samba-9579b9823707b9acadfd7bf24d1c540eacf53fc0.tar.bz2
samba-9579b9823707b9acadfd7bf24d1c540eacf53fc0.zip
Added OSF1 changes to HEAD (-lsecurity etc.)
groupdb/groupdb.c: Fixed compile error caught by IRIX compiler. utils/smbpasswd.c: Fixed SunOS optind, optarg problem. Jeremy. (This used to be commit 30af39ae1edf51d5d06a1764982e5df431c142ac)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in31
1 files changed, 29 insertions, 2 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 5435d59f76..2c6dc2878a 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -29,8 +29,8 @@ AC_HEADER_DIRENT
AC_HEADER_TIME
AC_HEADER_SYS_WAIT
AC_CHECK_HEADERS(sys/fcntl.h sys/select.h fcntl.h sys/time.h sys/unistd.h)
-AC_CHECK_HEADERS(unistd.h utime.h grp.h sys/id.h limits.h memory.h net/if.h)
-AC_CHECK_HEADERS(compat.h rpc/rpc.h rpc/types.h rpc/xdr.h rpc/auth.h )
+AC_CHECK_HEADERS(unistd.h utime.h grp.h sys/id.h limits.h memory.h net/route.h net/if.h)
+AC_CHECK_HEADERS(compat.h rpc/rpc.h rpc/types.h rpc/xdr.h rpc/auth.h rpc/clnt.h)
AC_CHECK_HEADERS(rpcsvc/yp_prot.h rpcsvc/ypclnt.h sys/param.h ctype.h )
AC_CHECK_HEADERS(sys/wait.h sys/resource.h sys/ioctl.h sys/mode.h)
AC_CHECK_HEADERS(sys/filio.h string.h strings.h stdlib.h sys/socket.h)
@@ -190,6 +190,11 @@ AC_CHECK_FUNCS(pread _pread __pread pread64 _pread64 __pread64)
AC_CHECK_FUNCS(pwrite _pwrite __pwrite pwrite64 _pwrite64 __pwrite64)
AC_CHECK_FUNCS(open64 _open64 __open64 creat64)
+if test x"$ac_cv_func_putprpwnam" = x"no"; then
+ AC_CHECK_LIB(security, putprpwnam, [LIBS="$LIBS -lsecurity";
+ AC_DEFINE(HAVE_PUTPRPWNAM)])
+fi
+
# this bit needs to be modified for each OS that is suported by
# smbwrapper. You need to specify how to created a shared library and
# how to compile C code to produce PIC object files
@@ -397,6 +402,28 @@ if test x"$samba_cv_HAVE_IRIX_SPECIFIC_CAPABILITIES" = x"yes"; then
AC_DEFINE(HAVE_IRIX_SPECIFIC_CAPABILITIES)
fi
+AC_CACHE_CHECK([for broken int32 typedef included by rpc/rpc.h],samba_cv_HAVE_BROKEN_INT32_FROM_RPC_RPC_H,[
+AC_TRY_COMPILE([#include <sys/types.h>
+#if defined(HAVE_RPC_RPC_H)
+#include <rpc/rpc.h>
+#endif],
+[#define int32 int],
+samba_cv_HAVE_BROKEN_INT32_FROM_RPC_RPC_H=yes,samba_cv_HAVE_BROKEN_INT32_FROM_RPC_RPC_H=no)])
+if test x"$samba_cv_HAVE_BROKEN_INT32_FROM_RPC_RPC_H" = x"yes"; then
+ AC_DEFINE(HAVE_BROKEN_INT32_FROM_RPC_RPC_H)
+fi
+
+AC_CACHE_CHECK([for broken uint32 typedef included by rpc/rpc.h],samba_cv_HAVE_BROKEN_UINT32_FROM_RPC_RPC_H,[
+AC_TRY_COMPILE([#include <sys/types.h>
+#if defined(HAVE_RPC_RPC_H)
+#include <rpc/rpc.h>
+#endif],
+[#define uint32 unsigned int],
+samba_cv_HAVE_BROKEN_UINT32_FROM_RPC_RPC_H=yes,samba_cv_HAVE_BROKEN_UINT32_FROM_RPC_RPC_H=no)])
+if test x"$samba_cv_HAVE_BROKEN_UINT32_FROM_RPC_RPC_H" = x"yes"; then
+ AC_DEFINE(HAVE_BROKEN_UINT32_FROM_RPC_RPC_H)
+fi
+
AC_MSG_CHECKING([for test routines])
AC_TRY_RUN([#include "${srcdir-.}/tests/trivial.c"],
AC_MSG_RESULT(yes),