summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorVolker Lendecke <vl@samba.org>2011-10-31 16:30:38 +0100
committerVolker Lendecke <vlendec@samba.org>2011-11-30 12:47:27 +0100
commit99f2177e8fbf7f288fa896a0c64bfb6ae03b9ada (patch)
treeb06560ce319132a7887060f1674fe838c6c18dfd /source3/configure.in
parentda992be64f39364fbb8bca26e9421c7a36c49ac6 (diff)
downloadsamba-99f2177e8fbf7f288fa896a0c64bfb6ae03b9ada.tar.gz
samba-99f2177e8fbf7f288fa896a0c64bfb6ae03b9ada.tar.bz2
samba-99f2177e8fbf7f288fa896a0c64bfb6ae03b9ada.zip
s3-ctdb: Make use of CTDB_CONTROL_CHECK_SRVIDS
This should be a lot quicker than PROCESS_EXISTS followed by looking at serverid.tdb Autobuild-User: Volker Lendecke <vlendec@samba.org> Autobuild-Date: Wed Nov 30 12:47:27 CET 2011 on sn-devel-104
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in23
1 files changed, 23 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 529b29b044..46c98aa12c 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -5548,6 +5548,29 @@ if test "x$have_cluster_support" = "xyes" ; then
fi
if test "x$have_cluster_support" = "xyes" ; then
+ AC_HAVE_DECL(CTDB_CONTROL_CHECK_SRVIDS,[
+ #include "confdefs.h"
+ #define NO_CONFIG_H
+ #include "replace.h"
+ #include "system/wait.h"
+ #include "system/network.h"
+ #include <talloc.h>
+ #include <tdb.h>
+ #include <ctdb.h>
+ #include <ctdb_private.h>
+ ])
+ if test x"$ac_cv_have_CTDB_CONTROL_CHECK_SRVIDS_decl" != x"yes"
+ then
+ if test "x$enable_old_ctdb" = "xyes" ; then
+ AC_MSG_WARN([ignoring missing CHECK_SRVIDS (--enable-old-ctdb)])
+ else
+ ctdb_broken="support for CHECK_SRVIDS control missing"
+ have_cluster_support=no
+ fi
+ fi
+fi
+
+if test "x$have_cluster_support" = "xyes" ; then
# In ctdb 1.0.57, ctdb_control_tcp was temporarily renamed
# to ctdb_tcp_client.
AC_CHECK_TYPE(struct ctdb_tcp_client,[