summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJim McDonough <jmcd@samba.org>2003-01-17 20:57:26 +0000
committerJim McDonough <jmcd@samba.org>2003-01-17 20:57:26 +0000
commit9eb368e068076f65083916573cf832988e216b59 (patch)
treefb9cb68de693b1ac563abb748f899aebae6890de /source3/configure.in
parent8305409e797f9b62dad0720141ca8ed2f802a22b (diff)
downloadsamba-9eb368e068076f65083916573cf832988e216b59.tar.gz
samba-9eb368e068076f65083916573cf832988e216b59.tar.bz2
samba-9eb368e068076f65083916573cf832988e216b59.zip
Enable dynamic loading of RPC modules. See docs/textdocs/RPC_PLUGGIN.txt for instructions.
(This used to be commit d51e12df78ff8fc721d693fedbd1c633f39edd49)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in55
1 files changed, 54 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index ee94c89b40..4daba5a647 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -149,6 +149,14 @@ AC_SUBST(SMBWRAPPER)
AC_SUBST(EXTRA_BIN_PROGS)
AC_SUBST(EXTRA_SBIN_PROGS)
AC_SUBST(EXTRA_ALL_TARGETS)
+AC_SUBST(LSA_DYNAMIC)
+AC_SUBST(NETLOG_DYNAMIC)
+AC_SUBST(SAMR_DYNAMIC)
+AC_SUBST(SVC_DYNAMIC)
+AC_SUBST(WKS_DYNAMIC)
+AC_SUBST(REG_DYNAMIC)
+AC_SUBST(SPOOLSS_DYNAMIC)
+AC_SUBST(DFS_DYNAMIC)
# compile with optimization and without debugging by default
CFLAGS="-O ${CFLAGS}"
@@ -179,6 +187,52 @@ then
LIBS="$LIBS -ldmalloc"
fi
+AC_ARG_ENABLE(dynrpc, [ --enable-dynrpc Enable dynamic RPC modules [default=no]])
+
+if test x$enable_dynrpc = xyes
+then
+ enable_dynrpc=lsa,samr,reg,wks,netlog,dfs
+fi
+
+if test x$enable_dynrpc != xno
+then
+ for i in `echo $enable_dynrpc | sed -e's/,/ /g'`
+ do case $i in lsa)
+ LSA_DYNAMIC=yes
+ AC_DEFINE(RPC_LSA_DYNAMIC, 1,
+ [Define to make the LSA pipe dynamic])
+ ;; samr)
+ SAMR_DYNAMIC=yes
+ AC_DEFINE(RPC_SAMR_DYNAMIC, 1,
+ [Define to make the SAMR pipe dynamic])
+ ;; svc)
+ SVC_DYNAMIC=yes
+ AC_DEFINE(RPC_SVC_DYNAMIC, 1,
+ [Define to make the SRVSVC pipe dynamic])
+ ;; wks)
+ WKS_DYNAMIC=yes
+ AC_DEFINE(RPC_WKS_DYNAMIC, 1,
+ [Define to make the WKSSVC pipe dynamic])
+ ;; netlog)
+ NETLOG_DYNAMIC=yes
+ AC_DEFINE(RPC_NETLOG_DYNAMIC, 1,
+ [Define to make the NETLOGON pipe dynamic])
+ ;; reg)
+ REG_DYNAMIC=yes
+ AC_DEFINE(RPC_REG_DYNAMIC, 1,
+ [Define to make the WINREG pipe dynamic])
+ ;; spoolss)
+ SPOOLSS_DYNAMIC=yes
+ AC_DEFINE(RPC_SPOOLSS_DYNAMIC, 1,
+ [Define to make the SPOOLSS pipe dynamic])
+ ;; dfs)
+ DFS_DYNAMIC=yes
+ AC_DEFINE(RPC_DFS_DYNAMIC, 1,
+ [Define to make the NETDFS pipe dynamic])
+ ;; esac
+ done
+fi
+
dnl Checks for programs.
AC_PROG_CC
AC_PROG_INSTALL
@@ -1026,7 +1080,6 @@ if test $ac_cv_shlib_works = no; then
fi
fi
-
# this updates our target list if we can build shared libs
if test $BLDSHARED = true; then
LIBSMBCLIENT_SHARED=bin/libsmbclient.$SHLIBEXT