summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2003-01-19 22:25:34 +0000
committerJeremy Allison <jra@samba.org>2003-01-19 22:25:34 +0000
commita45db02a82a42d6ac616c3a1efe73272ccbd69b5 (patch)
tree8096328fbebc576fc187d612111b1b217daaa94e /source3/configure.in
parent52b65f70caa1c6ac3f978cd3a349de921fe1eea7 (diff)
downloadsamba-a45db02a82a42d6ac616c3a1efe73272ccbd69b5.tar.gz
samba-a45db02a82a42d6ac616c3a1efe73272ccbd69b5.tar.bz2
samba-a45db02a82a42d6ac616c3a1efe73272ccbd69b5.zip
Merge in more of the SuSE patches for Heimdal. These changes show how
to add a function without an explicit #ifdef HEIMDAL which I'm trying to avoid. Jeremy. (This used to be commit 77aeb262ef7c7cd3d206afe2d5445caaca943dfd)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 4daba5a647..d324a2ed6e 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2094,6 +2094,10 @@ fi
# Heimdal checks.
AC_CHECK_LIB(crypto, des_set_key, [LIBS="$LIBS -lcrypto"])
AC_CHECK_LIB(asn1, copy_Authenticator, [LIBS="$LIBS -lasn1 -lroken"])
+ AC_CHECK_LIB(krb5, krb5_set_real_time, [AC_DEFINE(HAVE_KRB5_SET_REAL_TIME,1,[Whether krb5_set_real_time is available])])
+ AC_CHECK_LIB(krb5, krb5_set_default_in_tkt_etypes, [AC_DEFINE(HAVE_KRB5_SET_DEFAULT_IN_TKT_ETYPES,1,[Whether krb5_set_default_in_tkt_etypes, is available])])
+ AC_CHECK_LIB(krb5, krb5_set_default_tgs_ktypes, [AC_DEFINE(HAVE_KRB5_SET_DEFAULT_TGS_KTYPES,1,[Whether krb5_set_default_tgs_ktypes is available])])
+
########################################################
# now see if we can find the krb5 libs in standard paths