summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorGerald Carter <jerry@samba.org>2003-01-30 17:04:47 +0000
committerGerald Carter <jerry@samba.org>2003-01-30 17:04:47 +0000
commita7f370972024bbc3935e3de231f2a2b3f80c7c0c (patch)
tree069fb4df8cebd2418609a4b1b1affade38199320 /source3/configure.in
parent4d26d86195c7db9b22d080bb54e2371bb8c5511d (diff)
downloadsamba-a7f370972024bbc3935e3de231f2a2b3f80c7c0c.tar.gz
samba-a7f370972024bbc3935e3de231f2a2b3f80c7c0c.tar.bz2
samba-a7f370972024bbc3935e3de231f2a2b3f80c7c0c.zip
Straus VOS detection patches from Paul Green
(This used to be commit 726181537db6bdd299fd9256a5e6def6b4b8ae33)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in24
1 files changed, 24 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 06066f28d9..81904273ef 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -411,6 +411,26 @@ case "$host_os" in
esac
;;
#
+# VOS may need to have POSIX support and System V compatibility enabled.
+#
+ *vos*)
+ case "$CPPFLAGS" in
+ *-D_POSIX_C_SOURCE*)
+ ;;
+ *)
+ CPPFLAGS="$CPPFLAGS -D_POSIX_C_SOURCE=199506L"
+ AC_DEFINE(_POSIX_C_SOURCE, 199506L, [Whether to enable POSIX support])
+ ;;
+ esac
+ case "$CPPFLAGS" in
+ *-D_SYSV*|*-D_SVID_SOURCE*)
+ ;;
+ *)
+ CPPFLAGS="$CPPFLAGS -D_SYSV"
+ AC_DEFINE(_SYSV, 1, [Whether to enable System V compatibility])
+ esac
+ ;;
+#
# Tests needed for SINIX large file support.
#
*sysv4*)
@@ -1082,6 +1102,10 @@ case "$host_os" in
LDSHFLAGS="-G"
AC_DEFINE(STAT_ST_BLOCKSIZE,512)
;;
+ *vos*) AC_DEFINE(STAT_ST_BLOCKSIZE,4096)
+ BLDSHARED="false"
+ LDSHFLAGS=""
+ ;;
*)
AC_DEFINE(STAT_ST_BLOCKSIZE,512)
;;