summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorMichael Adam <obnox@samba.org>2008-02-19 16:40:50 +0100
committerMichael Adam <obnox@samba.org>2008-02-19 17:39:40 +0100
commitb40d1b131b1c0a62c8c11395f8ce17e32385fae7 (patch)
treecf05b1f45bc3f66c3b3d3c376fa1765a2a28742a /source3/configure.in
parent5073bd13493fbfb158857ca0807424e631a29872 (diff)
downloadsamba-b40d1b131b1c0a62c8c11395f8ce17e32385fae7.tar.gz
samba-b40d1b131b1c0a62c8c11395f8ce17e32385fae7.tar.bz2
samba-b40d1b131b1c0a62c8c11395f8ce17e32385fae7.zip
configure: move more developer/test related checks up before the compiler checks.
Michael (This used to be commit 05e3095e21330c162624338160ab48d197cf0507)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in92
1 files changed, 46 insertions, 46 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 4a9dc0c139..91ae8d3e9d 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -276,6 +276,52 @@ AC_ARG_ENABLE(debug,
debug=yes
fi])
+#################################################
+# set prefix for 'make test'
+selftest_prefix="./"
+AC_SUBST(selftest_prefix)
+AC_ARG_WITH(selftest-prefix,
+[AS_HELP_STRING([--with-selftest-prefix=DIR], [The prefix where make test will be run ($selftest_prefix)])],
+[ case "$withval" in
+ yes|no)
+ AC_MSG_WARN([--with-selftest-prefix called without argument - will use default])
+ ;;
+ * )
+ selftest_prefix="$withval"
+ ;;
+ esac
+])
+
+#################################################
+# set path of samba4's smbtorture
+smbtorture4_path=""
+AC_SUBST(smbtorture4_path)
+AC_ARG_WITH(smbtorture4_path,
+[AS_HELP_STRING([--with-smbtorture4-path=PATH], [The path to a samba4 smbtorture for make test (none)])],
+[ case "$withval" in
+ yes|no)
+ AC_MSG_ERROR([--with-smbtorture4-path should take a path])
+ ;;
+ * )
+ smbtorture4_path="$withval"
+ if test -z "$smbtorture4_path" -a ! -f $smbtorture4_path; then
+ AC_MSG_ERROR(['$smbtorture_path' does not exist!])
+ fi
+ ;;
+ esac
+])
+
+AC_ARG_ENABLE(developer, [AS_HELP_STRING([--enable-developer], [Turn on developer warnings and debugging (default=no)])],
+ [if eval "test x$enable_developer = xyes"; then
+ developer=yes
+ fi])
+
+AC_ARG_ENABLE(krb5developer, [AS_HELP_STRING([--enable-krb5developer], [Turn on developer warnings and debugging, except -Wstrict-prototypes (default=no)])],
+ [if eval "test x$enable_krb5developer = xyes"; then
+ developer=yes
+ krb5_developer=yes
+ fi])
+
AC_ARG_WITH(cfenc,
[AS_HELP_STRING([--with-cfenc=HEADERDIR], [Use internal CoreFoundation encoding API for optimization (Mac OS X/Darwin only)])],
[
@@ -453,52 +499,6 @@ AC_ARG_ENABLE(swat,
AC_SUBST(SWAT_SBIN_TARGETS)
AC_SUBST(SWAT_INSTALL_TARGETS)
-#################################################
-# set prefix for 'make test'
-selftest_prefix="./"
-AC_SUBST(selftest_prefix)
-AC_ARG_WITH(selftest-prefix,
-[AS_HELP_STRING([--with-selftest-prefix=DIR], [The prefix where make test will be run ($selftest_prefix)])],
-[ case "$withval" in
- yes|no)
- AC_MSG_WARN([--with-selftest-prefix called without argument - will use default])
- ;;
- * )
- selftest_prefix="$withval"
- ;;
- esac
-])
-
-#################################################
-# set path of samba4's smbtorture
-smbtorture4_path=""
-AC_SUBST(smbtorture4_path)
-AC_ARG_WITH(smbtorture4_path,
-[AS_HELP_STRING([--with-smbtorture4-path=PATH], [The path to a samba4 smbtorture for make test (none)])],
-[ case "$withval" in
- yes|no)
- AC_MSG_ERROR([--with-smbtorture4-path should take a path])
- ;;
- * )
- smbtorture4_path="$withval"
- if test -z "$smbtorture4_path" -a ! -f $smbtorture4_path; then
- AC_MSG_ERROR(['$smbtorture_path' does not exist!])
- fi
- ;;
- esac
-])
-
-AC_ARG_ENABLE(developer, [AS_HELP_STRING([--enable-developer], [Turn on developer warnings and debugging (default=no)])],
- [if eval "test x$enable_developer = xyes"; then
- developer=yes
- fi])
-
-AC_ARG_ENABLE(krb5developer, [AS_HELP_STRING([--enable-krb5developer], [Turn on developer warnings and debugging, except -Wstrict-prototypes (default=no)])],
- [if eval "test x$enable_krb5developer = xyes"; then
- developer=yes
- krb5_developer=yes
- fi])
-
# Probe the gcc version for extra CFLAGS. We always stash these in
# DEVELOPER_CFLAGS, so that you can turn them on and off with a simple
# Makefile edit, avoiding the need to re-run configure.