summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorStefan Metzmacher <metze@samba.org>2012-01-24 13:48:33 +0100
committerStefan Metzmacher <metze@samba.org>2012-01-25 08:44:33 +0100
commitc74a522db14a71df6c0393b5aa5f382cc8205b5b (patch)
tree55f526faacb85b6cf4d42c2ab3eb82997b3f53a8 /source3/configure.in
parentda8e8e5fa5574eab635b9b7b7bb4ccd898889e85 (diff)
downloadsamba-c74a522db14a71df6c0393b5aa5f382cc8205b5b.tar.gz
samba-c74a522db14a71df6c0393b5aa5f382cc8205b5b.tar.bz2
samba-c74a522db14a71df6c0393b5aa5f382cc8205b5b.zip
s3:build: require gss_krb5_export_lucid_sec_context() for ads support
This is needed to detect krb5 with aes for GENSEC_FEATURE_NEW_SPNEGO at runtime. metze
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 1e09e48286..d309b982f6 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -3905,6 +3905,7 @@ if test x"$with_ads_support" != x"no"; then
AC_CHECK_FUNC_EXT(gss_oid_equal, $KRB5_LIBS)
AC_CHECK_FUNC_EXT(gss_inquire_sec_context_by_oid, $KRB5_LIBS)
AC_CHECK_FUNC_EXT(gss_wrap_iov, $KRB5_LIBS)
+ AC_CHECK_FUNC_EXT(gss_krb5_export_lucid_sec_context, $KRB5_LIBS)
# This is for FreeBSD (and possibly others). gss_mech_krb5 is a
# #define to GSS_KRB5_MECHANISM, which is defined in -lgssapi_krb5
@@ -4526,6 +4527,11 @@ if test x"$with_ads_support" != x"no"; then
fi
fi
+ if test x"$ac_cv_func_ext_gss_krb5_export_lucid_sec_context" != x"yes" ; then
+ AC_MSG_WARN(need gss_krb5_export_lucid_sec_context for SPNEGO and gss_wrap support)
+ use_ads=no
+ fi
+
if test x"$use_ads" = x"yes"; then
AC_DEFINE(WITH_ADS,1,[Whether to include Active Directory support])
AC_DEFINE(HAVE_KRB5,1,[Whether to have KRB5 support])