summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorMartin Pool <mbp@samba.org>2002-11-21 01:33:42 +0000
committerMartin Pool <mbp@samba.org>2002-11-21 01:33:42 +0000
commitd18bcbb1744a1b8f7d78f0a7df887c939e35dfb4 (patch)
treedb311810254c2744e194590aa29c80021196dad2 /source3/configure.in
parent3e1846d0deeb49589aa69ca5af58d80a31d486a2 (diff)
downloadsamba-d18bcbb1744a1b8f7d78f0a7df887c939e35dfb4.tar.gz
samba-d18bcbb1744a1b8f7d78f0a7df887c939e35dfb4.tar.bz2
samba-d18bcbb1744a1b8f7d78f0a7df887c939e35dfb4.zip
If you don't specify --with-python, we assume "python" anyhow, because
the extensions are not built until you specifically "make python_ext". (This used to be commit 47c5c2209e3999b8f58204c978b30a9dd646497a)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in12
1 files changed, 11 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index f8386e2275..fb2ed2ee73 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -3149,11 +3149,21 @@ AC_SUBST(FLAGS1)
# though they can coexist in different directories.) In the future
# this might make the Python stuff be built by default.
+# If you don't specify --with-python, we assume "python" anyhow,
+# because the extensions are not built until you specifically "make
+# python_ext". --without-python turns them off. Perhaps in the
+# future --with-python should make them automatically built by make
+# all.
+
+PYTHON=python
+
AC_ARG_WITH(python,
[ --with-python=PYTHONNAME build Python libraries],
[ case "${withval-python}" in
yes)
- PYTHON=python
+ ;;
+ no)
+ PYTHON=
;;
*)
PYTHON=${withval-python}