summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorTim Potter <tpot@samba.org>2003-06-20 06:41:56 +0000
committerTim Potter <tpot@samba.org>2003-06-20 06:41:56 +0000
commitd7dfff92c1f4239807a7c20c4346f9c9cdfe5ec7 (patch)
tree0d241451e94d184a729128648671dd2869e81b65 /source3/configure.in
parent5e37c04c032b0a775e17a7c953998bbe72ca6f02 (diff)
downloadsamba-d7dfff92c1f4239807a7c20c4346f9c9cdfe5ec7.tar.gz
samba-d7dfff92c1f4239807a7c20c4346f9c9cdfe5ec7.tar.bz2
samba-d7dfff92c1f4239807a7c20c4346f9c9cdfe5ec7.zip
The default action for AC_CHECK_LIB is to add the library to $LIBS so
this doesn't need to be done explicitly in the Kerberos checks. Also there was a duplicate AC_CHECK_LIB(resolv, dn_expand) which is done early on in the configure process. (This used to be commit fa66e2e1e1186d8c8965e1a13d49f4af2e71a442)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in13
1 files changed, 6 insertions, 7 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 9209f31283..6e293a4742 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2206,13 +2206,12 @@ fi
##################################################################
# we might need the k5crypto and com_err libraries on some systems
- AC_CHECK_LIB(com_err, _et_list, [LIBS="$LIBS -lcom_err"])
- AC_CHECK_LIB(k5crypto, krb5_encrypt_data, [LIBS="$LIBS -lk5crypto"])
+ AC_CHECK_LIB(com_err, _et_list)
+ AC_CHECK_LIB(k5crypto, krb5_encrypt_data)
# Heimdal checks.
- AC_CHECK_LIB(crypto, des_set_key, [LIBS="$LIBS -lcrypto"])
- AC_CHECK_LIB(asn1, copy_Authenticator, [LIBS="$LIBS -lasn1"])
- AC_CHECK_LIB(roken, roken_getaddrinfo_hostspec, [LIBS="$LIBS -lroken"])
- AC_CHECK_LIB(resolv, dn_expand, [LIBS="$LIBS -lresolv"])
+ AC_CHECK_LIB(crypto, des_set_key)
+ AC_CHECK_LIB(asn1, copy_Authenticator)
+ AC_CHECK_LIB(roken, roken_getaddrinfo_hostspec)
# Heimdal checks. On static Heimdal gssapi must be linked before krb5.
AC_CHECK_LIB(gssapi, gss_display_status, [LIBS="$LIBS -lgssapi -lkrb5";
AC_DEFINE(HAVE_GSSAPI,1,[Whether GSSAPI is available])])
@@ -2313,7 +2312,7 @@ if test x"$with_ldap_support" = x"yes"; then
##################################################################
# we might need the lber lib on some systems. To avoid link errors
# this test must be before the libldap test
- AC_CHECK_LIB(lber, ber_scanf, [LIBS="$LIBS -llber"])
+ AC_CHECK_LIB(lber, ber_scanf)
########################################################
# now see if we can find the ldap libs in standard paths