summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorTim Potter <tpot@samba.org>2002-12-03 05:44:36 +0000
committerTim Potter <tpot@samba.org>2002-12-03 05:44:36 +0000
commite21df94c52a51e57d50611e22c6dfc8017504d75 (patch)
treec2c26a26e3308e274552852b1d9b569f8c5d89c7 /source3/configure.in
parenta65dc990f85a627091f30ee7e079ef6c6814c054 (diff)
downloadsamba-e21df94c52a51e57d50611e22c6dfc8017504d75.tar.gz
samba-e21df94c52a51e57d50611e22c6dfc8017504d75.tar.bz2
samba-e21df94c52a51e57d50611e22c6dfc8017504d75.zip
Fixes for EXEEXT - must use \$ signs when you want an actual $ sign to
be used. (This used to be commit 8c306804c6f3f0523ff5347e4b9360474d696a50)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 107cc2c8d6..53b95990b2 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -739,7 +739,7 @@ fi
# Check if we have execl, if not we need to compile smbrun.
AC_CHECK_FUNCS(execl)
if test x"$ac_cv_func_execl" = x"no"; then
- EXTRA_BIN_PROGS="$EXTRA_BIN_PROGS bin/smbrun$(EXEEXT)"
+ EXTRA_BIN_PROGS="$EXTRA_BIN_PROGS bin/smbrun\$(EXEEXT)"
fi
AC_CHECK_FUNCS(dlopen dlclose dlsym dlerror waitpid getcwd strdup strndup strnlen strtoul strerror chown fchown chmod fchmod chroot link mknod mknod64)
@@ -1886,7 +1886,7 @@ AC_ARG_WITH(smbwrapper,
yes)
AC_MSG_RESULT(yes)
AC_DEFINE(WITH_SMBWRAPPER,1,[Whether to include smbwrapper support])
- WRAPPROG="bin/smbsh$(EXEEXT)"
+ WRAPPROG="bin/smbsh\$(EXEEXT)"
WRAP="bin/smbwrapper.$SHLIBEXT"
if test x$ATTEMPT_WRAP32_BUILD = x; then
@@ -3056,8 +3056,8 @@ if test x"$HAVE_WINBIND" = x"yes"; then
AC_MSG_RESULT(yes)
AC_DEFINE(WITH_WINBIND,1,[Whether to build winbind])
- EXTRA_BIN_PROGS="$EXTRA_BIN_PROGS bin/wbinfo$(EXEEXT)"
- EXTRA_SBIN_PROGS="$EXTRA_SBIN_PROGS bin/winbindd$(EXEEXT)"
+ EXTRA_BIN_PROGS="$EXTRA_BIN_PROGS bin/wbinfo\$(EXEEXT)"
+ EXTRA_SBIN_PROGS="$EXTRA_SBIN_PROGS bin/winbindd\$(EXEEXT)"
if test x"$BLDSHARED" = x"true"; then
SHLIB_PROGS="$SHLIB_PROGS nsswitch/libnss_winbind.so"
if test x"$with_pam" = x"yes"; then