summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJim McDonough <jmcd@samba.org>2003-02-03 18:10:27 +0000
committerJim McDonough <jmcd@samba.org>2003-02-03 18:10:27 +0000
commitf589ec26d2ebddf07ef1492df2ef9769eaf45146 (patch)
tree17596956c5bbf99ba0728611f4a66d6a954f2c89 /source3/configure.in
parent11245e0fc37563f695f4e23ce80db8f88b474557 (diff)
downloadsamba-f589ec26d2ebddf07ef1492df2ef9769eaf45146.tar.gz
samba-f589ec26d2ebddf07ef1492df2ef9769eaf45146.tar.bz2
samba-f589ec26d2ebddf07ef1492df2ef9769eaf45146.zip
Try to get build working on systems with krb runtime but not devel libs.
Let's not assume that because one dir exists the whole shebang is there... (This used to be commit 44fd5c827537bd14c2220f62f5e44190247ae556)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 2bf5f28c4f..87f2e0d0ac 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2107,7 +2107,7 @@ if test x$FOUND_KRB5 = x"no"; then
#################################################
# see if this box has the SuSE location for the heimdal kerberos implementation
AC_MSG_CHECKING(for /usr/include/heimdal)
-if test -d /usr/include/heimdal; then
+if test -d /usr/include/heimdal -a -f /usr/lib/heimdal/lib/libkrb5.a; then
LIBS="$LIBS -lkrb5"
CFLAGS="$CFLAGS -I/usr/include/heimdal"
CPPFLAGS="$CPPFLAGS -I/usr/include/heimdal"
@@ -2122,7 +2122,7 @@ if test x$FOUND_KRB5 = x"no"; then
#################################################
# see if this box has the RedHat location for kerberos
AC_MSG_CHECKING(for /usr/kerberos)
-if test -d /usr/kerberos; then
+if test -d /usr/kerberos -a -f /usr/kerberos/lib/libkrb5.a; then
LIBS="$LIBS -lkrb5"
LDFLAGS="$LDFLAGS -L/usr/kerberos/lib"
CFLAGS="$CFLAGS -I/usr/kerberos/include"