summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJames Peach <jpeach@samba.org>2007-11-18 13:56:19 -0800
committerJames Peach <jpeach@samba.org>2007-11-18 13:56:19 -0800
commitf8b9e720b2f2eb29f241d2ff9808f2f29ee603b0 (patch)
treec32831149222312ca92e39f0600dde6c6131b0df /source3/configure.in
parent882987594455c6676d0b01618d91bdbfc5e3b267 (diff)
downloadsamba-f8b9e720b2f2eb29f241d2ff9808f2f29ee603b0.tar.gz
samba-f8b9e720b2f2eb29f241d2ff9808f2f29ee603b0.tar.bz2
samba-f8b9e720b2f2eb29f241d2ff9808f2f29ee603b0.zip
Detect Heimdal Kerberos on OpenBSD 4.2.
Patch from Sean McCreary <samba-technical@mcwest.org>. (This used to be commit 8b0bee7c7688a966777f502c97922d7ad40d841c)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index d37e3925aa..69a8e3f023 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -3671,10 +3671,12 @@ if test x"$with_ads_support" != x"no"; then
KRB5_CFLAGS="-I/usr/include/heimdal"
KRB5_CPPFLAGS="-I/usr/include/heimdal"
KRB5_LDFLAGS="-L/usr/lib/heimdal/lib"
+ FOUND_KRB5=yes
AC_MSG_RESULT(yes)
else
KRB5_CFLAGS="-I/usr/include/heimdal"
KRB5_CPPFLAGS="-I/usr/include/heimdal"
+ FOUND_KRB5=yes
AC_MSG_RESULT(yes)
fi
else
@@ -3690,6 +3692,21 @@ if test x"$with_ads_support" != x"no"; then
KRB5_LDFLAGS="-L/usr/kerberos/lib"
KRB5_CFLAGS="-I/usr/kerberos/include"
KRB5_CPPFLAGS="-I/usr/kerberos/include"
+ FOUND_KRB5=yes
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_RESULT(no)
+ fi
+ fi
+
+ if test x$FOUND_KRB5 = x"no"; then
+ #################################################
+ # see if this box has the OpenBSD location for heimdal krb5
+ AC_MSG_CHECKING(for /usr/include/kerberosV)
+ if test -d /usr/include/kerberosV; then
+ KRB5_CPPFLAGS="-I/usr/include/kerberosV"
+ KRB5_LIBS="-lcrypto"
+ FOUND_KRB5=yes
AC_MSG_RESULT(yes)
else
AC_MSG_RESULT(no)