summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorGünther Deschner <gd@samba.org>2009-11-27 01:06:36 +0100
committerGünther Deschner <gd@samba.org>2009-11-27 01:40:35 +0100
commit1a8f8382740e352a83133b8c49aaedd4716210cd (patch)
tree226332c76ea2fce0b6caa190647277ba58eb790c /source3/configure.in
parent49e464cef5ed75976fcd6c544bffbd4391f3a1b6 (diff)
downloadsamba-1a8f8382740e352a83133b8c49aaedd4716210cd.tar.gz
samba-1a8f8382740e352a83133b8c49aaedd4716210cd.tar.bz2
samba-1a8f8382740e352a83133b8c49aaedd4716210cd.zip
s3-kerberos: Fix Bug #6929: build with recent heimdal.
Heimdal changed the KRB5_DEPRECATED define (which now may not take an identifier for activation) in new releases (like 1.3.1). Guenther
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 29016c5d86..693fe6a061 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -3362,6 +3362,25 @@ if test x"$with_ads_support" != x"no"; then
EXTRA_ALL_TARGETS="$EXTRA_ALL_TARGETS $WINBIND_KRB5_LOCATOR"
fi
fi
+
+ # check for new heimdal KRB5_DEPRECATED handling
+
+ AC_CACHE_CHECK([for KRB5_DEPRECATED define taking an identifier],
+ samba_cv_HAVE_KRB5_DEPRECATED_WITH_IDENTIFIER,[
+ AC_TRY_COMPILE(
+ [#define KRB5_DEPRECATED 1
+ #include <krb5.h>],
+ [void main(void) {}],
+ samba_cv_HAVE_KRB5_DEPRECATED_WITH_IDENTIFIER=yes,
+ samba_cv_HAVE_KRB5_DEPRECATED_WITH_IDENTIFIER=no)])
+
+ if test x"$samba_cv_HAVE_KRB5_DEPRECATED_WITH_IDENTIFIER" = x"yes"; then
+ AC_DEFINE(KRB5_DEPRECATED, 1,
+ [Whether to use deprecated krb5 interfaces])
+ else
+ AC_DEFINE(KRB5_DEPRECATED,,
+ [Whether to use deprecated krb5 interfaces])
+ fi
fi
# Now we have determined whether we really want ADS support