summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Bartlett <abartlet@samba.org>2001-11-28 06:52:33 +0000
committerAndrew Bartlett <abartlet@samba.org>2001-11-28 06:52:33 +0000
commit299edaa854944496dab0aea60d3adb86ce11af76 (patch)
tree73a0005933b69057b95a5073b50443c49e9a53a6 /source3/configure.in
parentb1ade347057438e05fcb412ba6d4c59d9ad0a4db (diff)
downloadsamba-299edaa854944496dab0aea60d3adb86ce11af76.tar.gz
samba-299edaa854944496dab0aea60d3adb86ce11af76.tar.bz2
samba-299edaa854944496dab0aea60d3adb86ce11af76.zip
Allow kerberos to work on RedHat and other non /usr systems again
the configure test uses the CPPFLAGS when checking that krb5.h exists (This used to be commit 1e4fc749ad17114ac715c8ab833ef1d50dd318da)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index bf02ba9d8b..d51446a5fe 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1611,6 +1611,7 @@ AC_MSG_CHECKING(for /usr/kerberos)
if test -d /usr/kerberos; then
LDFLAGS="$LDFLAGS -L/usr/kerberos/lib"
CFLAGS="$CFLAGS -I/usr/kerberos/include"
+ CPPFLAGS="$CPPFLAGS -I/usr/kerberos/include"
AC_MSG_RESULT(yes)
else
AC_MSG_RESULT(no)
@@ -1629,6 +1630,7 @@ AC_ARG_WITH(krb5,
AC_MSG_RESULT(yes)
LIBS="$LIBS -lkrb5"
CFLAGS="$CFLAGS -I$withval/include"
+ CPPFLAGS="$CPPFLAGS -I$withval/include"
LDFLAGS="$LDFLAGS -L$withval/lib"
AC_DEFINE(HAVE_KRB5)
have_krb5=yes;