summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2002-08-28 04:54:43 +0000
committerJelmer Vernooij <jelmer@samba.org>2002-08-28 04:54:43 +0000
commit2b2b0f7119fe043f61259579ce70e782f5f9ec5f (patch)
tree4f01756afc8aaeb48a01c76aa34f1b63392a6848 /source3/configure.in
parent61e4ee500f70939b95fb293ec4005e481f95076a (diff)
downloadsamba-2b2b0f7119fe043f61259579ce70e782f5f9ec5f.tar.gz
samba-2b2b0f7119fe043f61259579ce70e782f5f9ec5f.tar.bz2
samba-2b2b0f7119fe043f61259579ce70e782f5f9ec5f.zip
Put in intermediate version of new SAM system. It's not stable yet, code
might be ugly, etc - please don't blame me for anything but instead try to fix the code :-). Compiling of the new sam system can be enabled with the configure option --with-sam Removing passdb/passgrp.c as it's unused fix typo in utils/testparm.c (This used to be commit 4b7de5ee236c043e6169f137992baf09a95c6f2c)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index de8da34091..e4bc698257 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2138,6 +2138,22 @@ if test x"$samba_cv_HAVE_TRUNCATED_SALT" = x"yes"; then
fi
fi
+# New experimental SAM system
+
+AC_MSG_CHECKING([whether to build the new (experimental) SAM database])
+AC_ARG_WITH(sam,
+[ --with-sam Build new (experimental) SAM database (default=no)],
+[ case "$withval" in
+ yes)
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(WITH_SAM)
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+ esac ],
+ AC_MSG_RESULT(no)
+)
########################################################################################