summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2009-05-08 11:31:34 -0700
committerJeremy Allison <jra@samba.org>2009-05-08 11:39:05 -0700
commit3d6f4a7af7b91d9f9ac9fd0b00af63bb23e371f7 (patch)
tree3f5c0bc15c8c95eff144cc0c3bf3279becd417f7 /source3/configure.in
parentf47b220ce1bd8632205679bbba8f679f4470360b (diff)
downloadsamba-3d6f4a7af7b91d9f9ac9fd0b00af63bb23e371f7.tar.gz
samba-3d6f4a7af7b91d9f9ac9fd0b00af63bb23e371f7.tar.bz2
samba-3d6f4a7af7b91d9f9ac9fd0b00af63bb23e371f7.zip
Fix bug #6330 - DFS doesn't work on AIX. Jeremy.
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index b532372bfd..b6cdcc86ad 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -5703,6 +5703,16 @@ fi
AC_HAVE_DECL(splice, [#include <fcntl.h>])
+############################################
+# See if we have the a broken readlink syscall.
+
+AC_CACHE_CHECK([for a broken readlink syscall],samba_cv_HAVE_BROKEN_READLINK,[
+AC_TRY_RUN([#include "${srcdir-.}/../tests/readlink.c"],
+ samba_cv_HAVE_BROKEN_READLINK=no,samba_cv_HAVE_BROKEN_READLINK=yes,samba_cv_HAVE_BROKEN_READLINK=cross)
+])
+if test x"$samba_cv_HAVE_BROKEN_READLINK" = x"yes"; then
+ AC_DEFINE(HAVE_BROKEN_READLINK,1,[Whether the readlink syscall is broken])
+fi
#################################################
# Check whether winbind is supported on this platform. If so we need to