summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Tridgell <tridge@samba.org>2001-11-20 08:54:15 +0000
committerAndrew Tridgell <tridge@samba.org>2001-11-20 08:54:15 +0000
commit6464bb0ae5d2cb774ccd5187f65a6ff83c051ed9 (patch)
tree870841ead9af4ffb6885c0ace99cd4b7fc401836 /source3/configure.in
parentb1a2ba890aec9463110513ba2ce7ed1e81537cce (diff)
downloadsamba-6464bb0ae5d2cb774ccd5187f65a6ff83c051ed9.tar.gz
samba-6464bb0ae5d2cb774ccd5187f65a6ff83c051ed9.tar.bz2
samba-6464bb0ae5d2cb774ccd5187f65a6ff83c051ed9.zip
added the beginnings of ADS support in smbd
(This used to be commit c7f611691941ca92f57665e19d6e46b161599427)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in20
1 files changed, 14 insertions, 6 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 506a34d941..534be53dc9 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -249,7 +249,7 @@ AC_CHECK_HEADERS(sys/param.h ctype.h sys/wait.h sys/resource.h sys/ioctl.h sys/i
AC_CHECK_HEADERS(sys/mman.h sys/filio.h sys/priv.h sys/shm.h string.h strings.h stdlib.h sys/socket.h)
AC_CHECK_HEADERS(sys/mount.h sys/vfs.h sys/fs/s5param.h sys/filsys.h termios.h termio.h)
AC_CHECK_HEADERS(sys/termio.h sys/statfs.h sys/dustat.h sys/statvfs.h stdarg.h sys/sockio.h)
-AC_CHECK_HEADERS(security/pam_modules.h security/_pam_macros.h)
+AC_CHECK_HEADERS(security/pam_modules.h security/_pam_macros.h ldap.h sasl.h)
#
# HPUX has a bug in that including shadow.h causes a re-definition of MAXINT.
@@ -543,7 +543,7 @@ else
fi
AC_CHECK_FUNCS(waitpid getcwd strdup strtoul strerror chown fchown chmod fchmod chroot)
-AC_CHECK_FUNCS(fstat strchr utime utimes getrlimit fsync bzero memset)
+AC_CHECK_FUNCS(fstat strchr utime utimes getrlimit fsync bzero memset strlcpy strlcat)
AC_CHECK_FUNCS(memmove vsnprintf snprintf asprintf vasprintf setsid glob strpbrk pipe crypt16 getauthuid)
AC_CHECK_FUNCS(strftime sigprocmask sigblock sigaction sigset innetgr setnetgrent getnetgrent endnetgrent)
AC_CHECK_FUNCS(initgroups select poll rdchk getgrnam getgrent pathconf)
@@ -1626,6 +1626,11 @@ AC_ARG_WITH(krb5,
AC_MSG_RESULT(no)
)
+##################################################################
+# we might need the k5crypto and com_err libraries on some systems
+AC_CHECK_LIB(com_err, _et_list, [LIBS="$LIBS -lcom_err"])
+AC_CHECK_LIB(k5crypto, krb5_encrypt_data, [LIBS="$LIBS -lk5crypto"])
+
########################################################
# now see if we can find the krb5 libs in standard paths
@@ -1634,10 +1639,13 @@ AC_CHECK_LIB(krb5, krb5_mk_req_extended, [LIBS="$LIBS -lkrb5";
AC_DEFINE(HAVE_KRB5)])
fi
-##################################################################
-# we might need the k5crypto and com_err libraries on some systems
-AC_CHECK_LIB(com_err, _et_list, [LIBS="$LIBS -lcom_err"])
-AC_CHECK_LIB(k5crypto, krb5_encrypt_data, [LIBS="$LIBS -lk5crypto"])
+########################################################
+# now see if we can find the ldap libs in standard paths
+if test x$have_ldap != xyes; then
+AC_CHECK_LIB(ldap, ldap_open, [LIBS="$LIBS -lldap -llber";
+ AC_DEFINE(HAVE_LDAP)])
+fi
+
#################################################
# check for automount support