summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeremy Allison <jra@samba.org>2001-09-25 20:21:21 +0000
committerJeremy Allison <jra@samba.org>2001-09-25 20:21:21 +0000
commit6ddcd8a3bcef32694d9d753ff91cced71f5ca3a8 (patch)
tree45eca65d1dc6bc3534e1178a35cbeff6955a8295 /source3/configure.in
parentc1af3aabcf35e7d5d3bb82e9d0c7d2f15f6d5f26 (diff)
downloadsamba-6ddcd8a3bcef32694d9d753ff91cced71f5ca3a8.tar.gz
samba-6ddcd8a3bcef32694d9d753ff91cced71f5ca3a8.tar.bz2
samba-6ddcd8a3bcef32694d9d753ff91cced71f5ca3a8.zip
Fixup passdb stuff to add new nisplus and ldap backends.
Jeremy. (This used to be commit 611bf806d569b70edabbc04a2f5408142370a550)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in44
1 files changed, 22 insertions, 22 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 8fb238e8fa..52779ecff0 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1756,7 +1756,7 @@ AC_ARG_WITH(tdbsam,
[ case "$withval" in
yes)
AC_MSG_RESULT(yes)
- AC_DEFINE(WITH_TDBSAM)
+ AC_DEFINE(WITH_TDB_SAM)
;;
*)
AC_MSG_RESULT(no)
@@ -1767,14 +1767,15 @@ AC_ARG_WITH(tdbsam,
#################################################
# check for a LDAP password database
-AC_MSG_CHECKING(whether to use LDAP password database)
-AC_ARG_WITH(ldap,
-[ --with-ldapsam Include Experimental LDAP-Sam support (default=no)],
+AC_MSG_CHECKING(whether to use LDAP SAM database)
+AC_ARG_WITH(ldapsam,
+[ --with-ldapsam Include experimental LDAP SAM support (default=no)],
[ case "$withval" in
yes)
AC_MSG_RESULT(yes)
- AC_DEFINE(WITH_LDAP)
- AC_MSG_ERROR([LDAP password database not supported in this version.])
+ AC_DEFINE(WITH_LDAP_SAM)
+ LIBS="-lldap -llber -lresolv $LIBS"
+ with_smbpasswd_sam=no
;;
*)
AC_MSG_RESULT(no)
@@ -1784,23 +1785,22 @@ AC_ARG_WITH(ldap,
)
#################################################
-# commented out by --jerry
# check for a NISPLUS password database
-#AC_MSG_CHECKING(whether to use NISPLUS password database)
-#AC_ARG_WITH(nisplus,
-#[ --with-nisplus Include NISPLUS password database support
-#[ case "$withval" in
-# yes)
-# AC_MSG_RESULT(yes)
-# AC_DEFINE(WITH_NISPLUS)
-# ;;
-# *)
-# AC_MSG_RESULT(no)
-# ;;
-# esac ],
-# AC_MSG_RESULT(no)
-#)
-
+AC_MSG_CHECKING(whether to use NISPLUS SAM database)
+AC_ARG_WITH(nisplussam,
+[ --with-nisplussam Include NISPLUS SAM support (default=no)],
+[ case "$withval" in
+ yes)
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(WITH_NISPLUS_SAM)
+ with_smbpasswd_sam=no
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+ esac ],
+ AC_MSG_RESULT(no)
+)
#################################################
# check for a NISPLUS_HOME support
AC_MSG_CHECKING(whether to use NISPLUS_HOME)