summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorGünther Deschner <gd@samba.org>2007-12-18 11:24:10 +0100
committerGünther Deschner <gd@samba.org>2007-12-21 15:29:10 +0100
commit8f65326e9993a5caefde89f9a48cd677a9f0cefd (patch)
tree63abec62a2b7f8cc4e7c7504d65482adcb6b861b /source3/configure.in
parentf3476faa36adeacea4301aff823ec021588cca2e (diff)
downloadsamba-8f65326e9993a5caefde89f9a48cd677a9f0cefd.tar.gz
samba-8f65326e9993a5caefde89f9a48cd677a9f0cefd.tar.bz2
samba-8f65326e9993a5caefde89f9a48cd677a9f0cefd.zip
Build libnetapi shared and static if possible.
Guenther (This used to be commit 11e90dcbf5dd1a91118e6a5cee53735d72767c93)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in49
1 files changed, 49 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 6015837a2e..57b74a3db5 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -326,6 +326,10 @@ AC_SUBST(INSTALL_LIBSMBSHAREMODES)
AC_SUBST(UNINSTALL_LIBSMBSHAREMODES)
AC_SUBST(LIBSMBSHAREMODES_SHARED)
AC_SUBST(LIBSMBSHAREMODES)
+AC_SUBST(INSTALL_LIBNETAPI)
+AC_SUBST(UNINSTALL_LIBNETAPI)
+AC_SUBST(LIBNETAPI_SHARED)
+AC_SUBST(LIBNETAPI)
AC_SUBST(PRINT_LIBS)
AC_SUBST(AUTH_LIBS)
AC_SUBST(ACL_LIBS)
@@ -5067,6 +5071,51 @@ if test $enable_static = yes; then
fi
#################################################
+# should we build libnetapi?
+INSTALL_LIBNETAPI=
+UNINSTALL_LIBNETAPI=
+LIBNETAPI_SHARED=
+LIBNETAPI=
+AC_MSG_CHECKING(whether to build the libnetapi shared library)
+AC_ARG_WITH(libnetapi,
+[ --with-libnetapi Build the libnetapi shared library (default=no undefined API)],
+[ case "$withval" in
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+ yes)
+ if test $BLDSHARED = true; then
+ LIBNETAPI_SHARED=bin/libnetapi.$SHLIBEXT
+ LIBNETAPI=libnetapi
+ AC_MSG_RESULT(yes)
+ else
+ enable_static=yes
+ AC_MSG_RESULT(no shared library support -- will supply static library)
+ fi
+ if test $enable_static = yes; then
+ LIBNETAPI=libnetapi
+ fi
+ INSTALL_LIBNETAPI=installlibnetapi
+ UNINSTALL_LIBNETAPI=uninstalllibnetapi
+ ;;
+ esac ],
+[
+# if unspecified, default is to built it if possible.
+ if test $BLDSHARED = true; then
+ LIBNETAPI_SHARED=bin/libnetapi.$SHLIBEXT
+ LIBNETAPI=libnetapi
+ AC_MSG_RESULT(yes)
+ else
+ enable_static=yes
+ AC_MSG_RESULT(no shared library support -- will supply static library)
+ fi
+ if test $enable_static = yes; then
+ LIBNETAPI=libnetapi
+ fi]
+ INSTALL_LIBNETAPI=installlibnetapi
+)
+
+#################################################
# should we build libaddns?
INSTALL_LIBADDNS=
UNINSTALL_LIBADDNS=