summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorLars Müller <lmuelle@samba.org>2006-03-13 16:10:26 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 11:15:25 -0500
commit9b277916445e6c1bdc60e06c382067c209287aaf (patch)
tree34bf25c75d20de72b1dc0dc6d577c792dd345d37 /source3/configure.in
parentb97a69dce316ba8808b317acd99d976c4c279a28 (diff)
downloadsamba-9b277916445e6c1bdc60e06c382067c209287aaf.tar.gz
samba-9b277916445e6c1bdc60e06c382067c209287aaf.tar.bz2
samba-9b277916445e6c1bdc60e06c382067c209287aaf.zip
r14325: Add pam_modules rule which builds the configure(d) pam modules. This is
called as part of the all rule (again only if pam modules are requested by configure). Add pam_winbind rule. Ensure proto_exists before we build the pam modules. Add test_pam_modules rule to test if the built pam modules have any unresolved symbols. For test_pam_modules we use script/tests/dlopen.sh which was written by Nalin Dahyabhai <nalin@redhat.com>. Thanks Nalin! RedHat and SuSE use this script to test nss and pam modules since several years. (This used to be commit 71b2eb55adcd28f3796254ea1ce0bcee6098e712)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 7369b07959..fde1d6d950 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -256,6 +256,7 @@ AC_SUBST(IDMAP_LIBS)
AC_SUBST(KRB5_LIBS)
AC_SUBST(LDAP_LIBS)
AC_SUBST(SHLIB_PROGS)
+AC_SUBST(PAM_MODULES)
AC_SUBST(SMBWRAPPER)
AC_SUBST(SMBWRAP_OBJS)
AC_SUBST(SMBWRAP_INC)
@@ -3647,6 +3648,7 @@ AC_CHECK_LIB(pam, pam_get_data, [AC_DEFINE(HAVE_LIBPAM,1,[Whether libpam is avai
#################################################
# check for pam_smbpass support
+PAM_MODULES=""
AC_MSG_CHECKING(whether to use pam_smbpass)
AC_ARG_WITH(pam_smbpass,
[ --with-pam_smbpass Build PAM module for authenticating against passdb backends (default=no)],
@@ -3664,7 +3666,7 @@ AC_ARG_WITH(pam_smbpass,
AC_MSG_ERROR([No libpam found])
else
AUTH_LIBS="$AUTH_LIBS -lpam"
- SHLIB_PROGS="$SHLIB_PROGS bin/pam_smbpass.$SHLIBEXT"
+ PAM_MODULES="pam_smbpass"
fi
;;
*)
@@ -5110,7 +5112,7 @@ if test x"$HAVE_WINBIND" = x"yes"; then
SHLIB_PROGS="$SHLIB_PROGS $WINBIND_NSS $WINBIND_WINS_NSS"
if test x"$with_pam" = x"yes"; then
- SHLIB_PROGS="$SHLIB_PROGS bin/pam_winbind.$SHLIBEXT"
+ PAM_MODULES="$PAM_MODULES pam_winbind"
fi
fi
else