summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorDerrell Lipman <derrell@samba.org>2007-05-10 02:48:22 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 12:21:56 -0500
commitad3bed14f180c48e8d1ba57e7316398d81cc7d6b (patch)
treef284ba87a378bda1cf4df847c85b7ab93a94aa27 /source3/configure.in
parent1b55cf43849543babe0210ea0260752212a53f22 (diff)
downloadsamba-ad3bed14f180c48e8d1ba57e7316398d81cc7d6b.tar.gz
samba-ad3bed14f180c48e8d1ba57e7316398d81cc7d6b.tar.bz2
samba-ad3bed14f180c48e8d1ba57e7316398d81cc7d6b.zip
r22773: - Clean up the the rest of the cruft from my earlier work on the readahead()
missing declaration problem. (This used to be commit 44365130ce794e442f52ec7cf3fc51065f713c5f)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in12
1 files changed, 1 insertions, 11 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 8c728deea2..b938812812 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1333,10 +1333,6 @@ AC_CHECK_HEADERS(execinfo.h libexc.h libunwind.h)
AC_CHECK_FUNCS(backtrace_symbols)
AC_CHECK_LIB(exc, trace_back_stack)
-# Save the original CFLAGS for a few tests that we want to allow
-# implicit declaration warnings without failing the test (in developer mode)
-ac_no_error_on_warning_CFLAGS="${CFLAGS}"
-
echo -n "checking for GPFS GPL libs... "
save_LIBS="$LIBS"
LIBS="$LIBS -lgpfs_gpl"
@@ -4728,8 +4724,6 @@ if test x"$samba_cv_SYSQUOTA_FOUND" != x"no"; then
AC_CACHE_CHECK([whether the sys_quota interface works],samba_cv_SYSQUOTA_WORKS,[
SAVE_CPPFLAGS="$CPPFLAGS"
CPPFLAGS="$CPPFLAGS ${SAMBA_CONFIGURE_CPPFLAGS}"
-SAVE_CFLAGS="$CFLAGS"
-CFLAGS="${ac_no_error_on_warning_CFLAGS}"
AC_TRY_COMPILE([
#include "confdefs.h"
#define NO_PROTO_H 1
@@ -4739,7 +4733,6 @@ AC_TRY_COMPILE([
#include "${srcdir-.}/lib/sysquotas.c"
],[],samba_cv_SYSQUOTA_WORKS=yes,samba_cv_SYSQUOTA_WORKS=no)
CPPFLAGS="$SAVE_CPPFLAGS"
-CFLAGS="$SAVE_CFLAGS"
])
if test x"$samba_cv_SYSQUOTA_WORKS" = x"yes"; then
AC_MSG_CHECKING(whether to use the new lib/sysquotas.c interface)
@@ -4778,8 +4771,6 @@ fi
AC_CACHE_CHECK([whether the old quota support works],samba_cv_QUOTA_WORKS,[
SAVE_CPPFLAGS="$CPPFLAGS"
CPPFLAGS="$CPPFLAGS ${SAMBA_CONFIGURE_CPPFLAGS}"
-SAVE_CFLAGS="$CFLAGS"
-CFLAGS="${ac_no_error_on_warning_CFLAGS}"
AC_TRY_COMPILE([
#include "confdefs.h"
#define NO_PROTO_H 1
@@ -4787,7 +4778,6 @@ AC_TRY_COMPILE([
#include "${srcdir-.}/smbd/quotas.c"
],[],samba_cv_QUOTA_WORKS=yes,samba_cv_QUOTA_WORKS=no)
CPPFLAGS="$SAVE_CPPFLAGS"
-CFLAGS="$SAVE_CFLAGS"
])
if test x"$samba_cv_QUOTA_WORKS" = x"yes"; then
AC_MSG_CHECKING(whether to use the old quota support)
@@ -6377,7 +6367,7 @@ AC_TRY_RUN([#include "${srcdir-.}/tests/summary.c"],
dnl Merge in developer cflags from now on
if test x"$developer" = x"yes"; then
- CFLAGS="${ac_no_error_on_warning_CFLAGS} ${DEVELOPER_CFLAGS}"
+ CFLAGS="${CFLAGS} ${DEVELOPER_CFLAGS}"
fi
builddir=`pwd`