summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorStefan Metzmacher <metze@samba.org>2009-10-28 11:21:27 +0100
committerMichael Adam <obnox@samba.org>2009-10-28 13:08:26 +0100
commitee13e9c0becc2b4a4d3b233613d5e3e9bfb54938 (patch)
tree70f3a568cf5f97cfda48c16937ebcef482af2740 /source3/configure.in
parent4df8426768b96ae263fa54cdee86b6a13d5aea57 (diff)
downloadsamba-ee13e9c0becc2b4a4d3b233613d5e3e9bfb54938.tar.gz
samba-ee13e9c0becc2b4a4d3b233613d5e3e9bfb54938.tar.bz2
samba-ee13e9c0becc2b4a4d3b233613d5e3e9bfb54938.zip
s3:configure: only check for gpfs_gpl.h
The header is everything we need in order to build vfs_gpfs. metze Signed-off-by: Michael Adam <obnox@samba.org>
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in30
1 files changed, 5 insertions, 25 deletions
diff --git a/source3/configure.in b/source3/configure.in
index a296a59ca0..4a54e6670b 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1081,33 +1081,13 @@ AC_CHECK_LIB(exc, trace_back_stack)
# check for sysctlbyname for BSD systems
AC_CHECK_FUNCS(sysctlbyname)
-printf "%s" "checking for GPFS GPL libs... "
-save_LIBS="$LIBS"
-LIBS="$LIBS -lgpfs_gpl"
-AC_TRY_LINK([#include <gpfs_gpl.h>],
- [gpfs_set_share(0,GPFS_SHARE_READ,GPFS_DENY_NONE)],
- samba_cv_HAVE_GPFS=yes,
- samba_cv_HAVE_GPFS=no)
-echo $samba_cv_HAVE_GPFS
-if test x"$samba_cv_HAVE_GPFS" = x"yes"; then
- AC_DEFINE(HAVE_GPFS,1,[Whether GPFS GPL libs are available])
+#############################
+# check if building with gpfs
+AC_CHECK_HEADERS(gpfs_gpl.h)
+if test x"$ac_cv_header_gpfs_gpl_h" = x"yes"; then
+ AC_DEFINE(HAVE_GPFS,1,[Whether GPFS GPL headers are available])
default_shared_modules="$default_shared_modules vfs_gpfs"
fi
-LIBS="$save_LIBS"
-
-printf "%s" "checking for GPFS libs (with 3.2.1 PTF8 available as GPL)... "
-save_LIBS="$LIBS"
-LIBS="$LIBS -lgpfs"
-AC_TRY_LINK([#include <gpfs.h>],
- [gpfs_set_share(0,GPFS_SHARE_READ,GPFS_DENY_NONE)],
- samba_cv_HAVE_GPFS=yes,
- samba_cv_HAVE_GPFS=no)
-echo $samba_cv_HAVE_GPFS
-if test x"$samba_cv_HAVE_GPFS" = x"yes"; then
- AC_DEFINE(HAVE_GPFS,1,[Whether GPFS GPL libs are available])
- default_shared_modules="$default_shared_modules vfs_gpfs"
-fi
-LIBS="$save_LIBS"
#############################################
# check if building on Isilon OneFS