summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorGerald Carter <jerry@samba.org>2001-09-26 17:29:53 +0000
committerGerald Carter <jerry@samba.org>2001-09-26 17:29:53 +0000
commit2c4d1d39b148b8587deb8fca2db4113354165989 (patch)
treef03a460218b307deee916ca2746298d009315c53 /source3/configure.in
parent29d3318437f3137d61e955d5ee5d8f70c115e3d2 (diff)
downloadsamba-2c4d1d39b148b8587deb8fca2db4113354165989.tar.gz
samba-2c4d1d39b148b8587deb8fca2db4113354165989.tar.bz2
samba-2c4d1d39b148b8587deb8fca2db4113354165989.zip
OpenSSL merge from 2.2
(This used to be commit efc6df5a3914da9e7b792ccaccd1403c72c09f78)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in41
1 files changed, 27 insertions, 14 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 4d9b411cc4..ab26fa4b0b 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1854,7 +1854,8 @@ AC_ARG_WITH(nisplus-home,
AC_MSG_CHECKING(whether to use SSL)
AC_ARG_WITH(ssl,
[ --with-ssl Include SSL support (default=no)
- --with-sslinc=DIR Where the SSL includes are (defaults to /usr/local/ssl)],
+ --with-sslinc=DIR Where the SSL includes are (defaults to /usr/local/ssl/include)
+ --with-ssllib=DIR Where the SSL libraries are (defaults to /usr/local/ssl/lib)],
[ case "$withval" in
yes)
AC_MSG_RESULT(yes)
@@ -1868,31 +1869,43 @@ AC_ARG_WITH(ssl,
yes|no)
echo "configure: warning: --with-sslinc called without argument - will use default" 1>&w
CFLAGS="-I/usr/local/ssl/include $CFLAGS"
- LIBS="-lssl -lcrypto $LIBS"
- LDFLAGS="=L/usr/local/ssl/lib $LDFLAGS"
- AC_DEFINE(SSL_DIR, "/usr/local/ssl")
;;
* )
CFLAGS="-I${withval} $CFLAGS"
- LIBS="-lssl -lcrypto $LIBS"
- LDFLAGS="-L${withval}/lib $LDFLAGS"
- AC_DEFINE_UNQUOTED(SSL_DIR, "${withval}", Used for determining the compile time options)
;;
esac
else
CFLAGS="-I/usr/local/ssl/include $CFLAGS"
- LIBS="-lssl -lcrypto $LIBS"
+
+ fi
+
+ if test "${with_ssllib+set}" = set; then
+
+ withval="$with_ssllib"
+ case "$withval" in
+ yes|no)
+ echo "configure: warning: --with-ssllib called without argument - will use default" 1>&w
+ LDFLAGS="-L/usr/local/ssl/lib $LDFLAGS"
+ ;;
+ * )
+ LDFLAGS="-L${withval}/lib $LDFLAGS"
+ ;;
+ esac
+
+ else
+
LDFLAGS="-L/usr/local/ssl/lib $LDFLAGS"
- AC_DEFINE(SSL_DIR, "/usr/local/ssl")
fi
-
- if test ! -d ${withval}; then
- echo "configure: error: called with --with-ssl, but ssl base directory ${withval} does not exist or is not a directory. Aborting config" 1>&2
- exit 1
- fi
+
+ LIBS="-lssl -lcrypto $LIBS"
+
+# if test ! -d ${withval}; then
+# echo "configure: error: called with --with-ssl, but ssl base directory ${withval} does not exist or is not a directory. Aborting config" 1>&2
+# exit 1
+# fi
CFLAGS="-DHAVE_CRYPT_DECL $CFLAGS" # Damn, SSLeay defines its own