summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorVolker Lendecke <vl@samba.org>2013-01-07 12:53:27 -0800
committerJeremy Allison <jra@samba.org>2013-01-14 13:21:58 -0800
commit584402a71a4dd4bc821a58087814a1f3c110bb65 (patch)
tree977fd9043679064d3bf5b967aa24333dfc7a86e6 /source3/configure.in
parente0bfb59803184c44cfc354b99ba3d8d7bbfc72b9 (diff)
downloadsamba-584402a71a4dd4bc821a58087814a1f3c110bb65.tar.gz
samba-584402a71a4dd4bc821a58087814a1f3c110bb65.tar.bz2
samba-584402a71a4dd4bc821a58087814a1f3c110bb65.zip
configure: Fix bug 9546, aio_suspend detection on FreeBSD
NULL is not defined without some includes Reviewed by: Jeremy Allison <jra@samba.org>
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 359113143b..0fa58590f5 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -5386,7 +5386,7 @@ int main() { struct aiocb a; return aio_cancel(1, &a); }])],
AC_MSG_CHECKING(for aio_suspend)
AC_LINK_IFELSE([AC_LANG_SOURCE([#include <aio.h>
-int main() { struct aiocb a; return aio_suspend(&a, 1, NULL); }])],
+int main() { struct aiocb a; struct timespec t; return aio_suspend(&a, 1, &t); }])],
[AC_DEFINE(HAVE_AIO_SUSPEND, 1, [Have aio_suspend]) AC_MSG_RESULT(yes)],
[AC_MSG_RESULT(no)])
else