summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Tridgell <tridge@samba.org>2001-10-14 14:04:55 +0000
committerAndrew Tridgell <tridge@samba.org>2001-10-14 14:04:55 +0000
commit8732ff135a516d6d2b7678552035102f0d087c01 (patch)
tree4f8caac4030211b5981cd35b5da6f24c3a9067fd /source3/configure.in
parent189cf0d3a024cabf80c05b33461d0789ceb6e37d (diff)
downloadsamba-8732ff135a516d6d2b7678552035102f0d087c01.tar.gz
samba-8732ff135a516d6d2b7678552035102f0d087c01.tar.bz2
samba-8732ff135a516d6d2b7678552035102f0d087c01.zip
fixed the --with-krb5=dir option.
thanks to monyo for pointing out the problem (This used to be commit 5a6774c43897e75a152b751f18a8bc323a4b6ef5)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in17
1 files changed, 9 insertions, 8 deletions
diff --git a/source3/configure.in b/source3/configure.in
index c5e1492766..778990c567 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -321,7 +321,7 @@ AC_CHECK_LIB(dl, dlopen, [LIBS="$LIBS -ldl";
AC_DEFINE(HAVE_LIBDL)])
############################################
-# we need krb5 for w2k ADS authentication
+# we need kerberos 5 for w2k ADS authentication
AC_CHECK_LIB(krb5, krb5_mk_req_extended, [LIBS="$LIBS -lkrb5";
AC_DEFINE(HAVE_KRB5)])
@@ -1612,22 +1612,23 @@ AC_ARG_WITH(krb4,
)
#################################################
-# check for Kerberos 5 auth system
-AC_MSG_CHECKING(whether to use Kerberos 5)
+# check for location of Kerberos 5 install
+AC_MSG_CHECKING(for kerberos 5 install)
AC_ARG_WITH(krb5,
[ --with-krb5=base-dir Include Kerberos 5 support (default=no)],
[ case "$withval" in
- yes)
+ no)
+ AC_MSG_RESULT(no)
+ ;;
+ *)
AC_MSG_RESULT(yes)
AC_DEFINE(KRB5_AUTH)
- LIBS="$LIBS -ldes425 -lkrb5 -lcrypto -lcom_err"
+ LIBS="$LIBS -lkrb5"
CFLAGS="$CFLAGS -I$withval/include"
LDFLAGS="$LDFLAGS -L$withval/lib"
+ AC_DEFINE(HAVE_KRB5)
AC_DEFINE_UNQUOTED(KRB5_DIR,${withval})
;;
- *)
- AC_MSG_RESULT(no)
- ;;
esac ],
AC_MSG_RESULT(no)
)