summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorBjörn Jacke <bj@sernet.de>2009-12-02 15:13:37 +0100
committerBjörn Jacke <bj@sernet.de>2009-12-02 21:21:43 +0100
commit95c18626107484d5d1d475e34fc4dde03cfe6ff5 (patch)
tree508651f48665b308ec49ef600f7b58de0916c2a2 /source3/configure.in
parent486c8d57ec5a9aa63aff275621ff45c22b8cde61 (diff)
downloadsamba-95c18626107484d5d1d475e34fc4dde03cfe6ff5.tar.gz
samba-95c18626107484d5d1d475e34fc4dde03cfe6ff5.tar.bz2
samba-95c18626107484d5d1d475e34fc4dde03cfe6ff5.zip
s3: prefer posix_fallocate for doing "strict allocate"
posix_fallocate is more efficient than manual zero'ing the file. When preallocation in kernel space is supported it's extremely fast. Support for preallocation at fs layer via posix_fallocate and fallocate at kernel site can be found in Linux kernel 2.6.23/glibc 2.10 with ext4, XFS and OCFS2. Other systems that I know of which support fast preallocation in kernel space are AIX 6.1 with JFS2 and recent Solaris versions with ZFS maybe UFS2, too. People who have a system with preallocation in kernel space might want to set "strict allocate = yes". This reduces file fragentation and it's also safer for setups with quota being turned on. As of today most systems still don't have preallocation in kernel space, and that's why "strict allocate = no" will stay the default for now.
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index de30f143a9..fb1d6313e1 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1057,7 +1057,7 @@ AC_CHECK_FUNCS(setsid glob strpbrk crypt16 getauthuid)
AC_CHECK_FUNCS(sigprocmask sigblock sigaction sigset innetgr setnetgrent getnetgrent endnetgrent)
AC_CHECK_FUNCS(initgroups select poll rdchk getgrnam getgrent pathconf)
AC_CHECK_FUNCS(setpriv setgidx setuidx setgroups sysconf stat64 fstat64)
-AC_CHECK_FUNCS(lstat64 fopen64 atexit grantpt lseek64 ftruncate64)
+AC_CHECK_FUNCS(lstat64 fopen64 atexit grantpt lseek64 ftruncate64 posix_fallocate posix_fallocate64)
AC_CHECK_FUNCS(fseek64 fseeko64 ftell64 ftello64 setluid getpwanam)
AC_CHECK_FUNCS(opendir64 readdir64 seekdir64 telldir64 rewinddir64 closedir64)
AC_CHECK_FUNCS(getpwent_r)