summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorMotonobu Takahashi <monyo@samba.org>2001-09-24 15:55:09 +0000
committerMotonobu Takahashi <monyo@samba.org>2001-09-24 15:55:09 +0000
commit96db4b1ba3a48f50b80b2cfbf0b940e073b7843c (patch)
treebd8d1c25af214250053a84b71b668e81bef7ef5d /source3/configure.in
parent63dba7abe04c1d33bbfa5e921e4aa967dc3966c3 (diff)
downloadsamba-96db4b1ba3a48f50b80b2cfbf0b940e073b7843c.tar.gz
samba-96db4b1ba3a48f50b80b2cfbf0b940e073b7843c.tar.bz2
samba-96db4b1ba3a48f50b80b2cfbf0b940e073b7843c.zip
Added SWAT i18n feature:
TO enable configure with --with-i18n-swat to support this gettext is integrated and a new directories name "po" and "intl" are created. now these languages are supported: en - English (default) ja - Japanese po - Polish tr - Turkish To add your language, to create ${your_language}.po by translating source/po/en.po into your language is needed. some of html and image files of various language version are not included yet, though message catalogue files are installed. you need to copy files manually under ${swatdir}/lang/$ln/{help,images,included,using_samba} And also added a option to intall manual pages: of various lang version To enable configure with --with-manlangs but manual pages themself are not included yet. (This used to be commit 486b79a6fc4ba20a751aab544bd0f7ccff2b3d19)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in81
1 files changed, 80 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 030a273480..b9e8c94b42 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -2027,6 +2027,76 @@ AC_ARG_WITH(swatdir,
)
#################################################
+# check for i18n'ed SWAT compiling
+AC_MSG_CHECKING(whether to use i18n'ed SWAT)
+AC_ARG_WITH(i18n-swat,
+[ --with-i18n-swat Use i18n'ed SWAT
+ --without-i18n-swat Don't use i18n'ed SWAT (default)],
+[ case "$withval" in
+ yes)
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(I18N_SWAT)
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+ esac ],
+ AC_MSG_RESULT(no)
+)
+
+#################################################
+# set SWAT default language for old web browsers.
+AC_MSG_CHECKING(whether to use default SWAT language)
+AC_ARG_WITH(swat-def-lang,
+[ --with-swat-def-lang=LN default SWAT language for old web browsers (empty)],
+[
+ default_pref_lang=""
+ case "$withval" in
+ yes)
+ AC_MSG_WARN([--with-swat-def-lang called without argument - will use default])
+ ;;
+ no)
+ AC_MSG_RESULT(no)
+ ;;
+ *)
+ default_pref_lang="$withval"
+ AC_MSG_RESULT($withval)
+ ;;
+ esac
+ AC_DEFINE_UNQUOTED(I18N_DEFAULT_PREF_LANG, "$default_pref_lang")
+],
+[
+ default_pref_lang=""
+ AC_MSG_RESULT(no)
+ AC_DEFINE_UNQUOTED(I18N_DEFAULT_PREF_LANG, "$default_pref_lang")
+]
+)
+
+#################################################
+# choose native language(s) of man pages
+AC_MSG_CHECKING(chosen man pages' language(s))
+AC_ARG_WITH(manpages-langs,
+[ --with-manpages-langs={en,ja,pl} Choose man pages' language(s). (en)],
+[ case "$withval" in
+ yes|no)
+ AC_MSG_WARN(--with-manpages-langs called without argument - will use default)
+ manlangs="en"
+ ;;
+ *)
+ manlangs="$withval"
+ ;;
+ esac
+
+ AC_MSG_RESULT($manlangs)
+ manlangs=${manlangs//,/ } # replacing commas with spaces to produce a list
+ AC_SUBST(manlangs)],
+
+ [manlangs="en"
+ AC_MSG_RESULT($manlangs)
+ AC_SUBST(manlangs)]
+)
+
+#################################################
# these tests are taken from the GNU fileutils package
AC_CHECKING(how to get filesystem space usage)
space=no
@@ -2394,6 +2464,15 @@ AC_SUBST(WINBIND_LTARGETS)
AC_SUBST(WINBIND_PAM_PROGS)
#################################################
+# Check for SWAT i18n support
+
+PACKAGE=i18n_swat
+AC_DEFINE_UNQUOTED(PACKAGE, "$PACKAGE")
+AC_SUBST(PACKAGE)
+ALL_LINGUAS="en ja pl tr"
+AM_GNU_GETTEXT
+
+#################################################
# final configure stuff
echo "checking configure summary"
@@ -2404,4 +2483,4 @@ AC_TRY_RUN([#include "${srcdir-.}/tests/summary.c"],
builddir=`pwd`
AC_SUBST(builddir)
-AC_OUTPUT(include/stamp-h Makefile)
+AC_OUTPUT(include/stamp-h Makefile intl/Makefile po/Makefile.in)