summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Tridgell <tridge@samba.org>2001-10-16 11:40:09 +0000
committerAndrew Tridgell <tridge@samba.org>2001-10-16 11:40:09 +0000
commit9a2ce008e9f4e2a1599416473ac76bb8612a2113 (patch)
treee3cb71c63f3fd64f1a89a6e5094faeaa0f730c1d /source3/configure.in
parent7acc2b977c4829fb70df6e9a9c4ba6111366aabc (diff)
downloadsamba-9a2ce008e9f4e2a1599416473ac76bb8612a2113.tar.gz
samba-9a2ce008e9f4e2a1599416473ac76bb8612a2113.tar.bz2
samba-9a2ce008e9f4e2a1599416473ac76bb8612a2113.zip
fix linking of k5crypto library on openbsd
(This used to be commit 2667dea146169658f3c0290bb78dc5854c821eb4)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/source3/configure.in b/source3/configure.in
index dab7ab4ab3..f888db47ac 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -1611,7 +1611,7 @@ AC_ARG_WITH(krb5,
*)
AC_MSG_RESULT(yes)
AC_DEFINE(KRB5_AUTH)
- LIBS="$LIBS -lkrb5 -lk5crypto -lcom_err"
+ LIBS="$LIBS -lkrb5"
CFLAGS="$CFLAGS -I$withval/include"
LDFLAGS="$LDFLAGS -L$withval/lib"
AC_DEFINE(HAVE_KRB5)
@@ -1626,10 +1626,14 @@ AC_ARG_WITH(krb5,
########################################################
# now see if we can find the krb5 libs in standard paths
if test x$have_krb5 != xyes; then
-AC_CHECK_LIB(krb5, krb5_mk_req_extended, [LIBS="$LIBS -lkrb5 -lk5crypto -lcom_err";
+AC_CHECK_LIB(krb5, krb5_mk_req_extended, [LIBS="$LIBS -lkrb5";
AC_DEFINE(HAVE_KRB5)])
fi
+##################################################################
+# we might need the k5crypto and com_err libraries on some systems
+AC_CHECK_LIB(k5crypto, krb5_encrypt_data)
+AC_CHECK_LIB(com_err, _et_list)
#################################################
# check for automount support