summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Tridgell <tridge@samba.org>2001-09-22 07:50:08 +0000
committerAndrew Tridgell <tridge@samba.org>2001-09-22 07:50:08 +0000
commitb192746e77ac610e5de7e0ee62c8c79a7dce9c40 (patch)
tree66779de4812fd24e5fccafc002975e3eaf66209d /source3/configure.in
parent0492effcf36bc1229d0d2e9250b6c6c36af0b117 (diff)
downloadsamba-b192746e77ac610e5de7e0ee62c8c79a7dce9c40.tar.gz
samba-b192746e77ac610e5de7e0ee62c8c79a7dce9c40.tar.bz2
samba-b192746e77ac610e5de7e0ee62c8c79a7dce9c40.zip
fixed the Makefile so we don't rebuild libsmbclient and build_env.h
(and thus smbd) every time (This used to be commit e78d0a3615d74cdd023d2d623abc27ac59356ae0)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index f8e54f13b1..030a273480 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -18,7 +18,7 @@ AC_SUBST(PICFLAG)
AC_SUBST(PICSUFFIX)
AC_SUBST(POBAD_CC)
AC_SUBST(SHLIBEXT)
-AC_SUBST(BLDSHARED)
+AC_SUBST(LIBSMBCLIENT_SHARED)
# compile with optimisation and without debugging by default
CFLAGS="-O ${CFLAGS}"
@@ -739,6 +739,13 @@ case "$host_os" in
;;
esac
+# this updates our target list if we can build shared libs
+if test $BLDSHARED = true; then
+ LIBSMBCLIENT_SHARED=bin/libsmbclient.$SHLIBEXT
+else
+ LIBSMBCLIENT_SHARED=
+fi
+
################
AC_CACHE_CHECK([for long long],samba_cv_have_longlong,[