summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorGünther Deschner <gd@samba.org>2009-11-25 21:33:48 +0100
committerGünther Deschner <gd@samba.org>2009-11-25 21:39:49 +0100
commitc438b2b3923db66672ec82e795eef543de5fcb8a (patch)
tree024862e92a62801a6b6247ab0a7f6311d92ade82 /source3/configure.in
parent7ed6f9f0960885366800b1ca2ce9558414b62d54 (diff)
downloadsamba-c438b2b3923db66672ec82e795eef543de5fcb8a.tar.gz
samba-c438b2b3923db66672ec82e795eef543de5fcb8a.tar.bz2
samba-c438b2b3923db66672ec82e795eef543de5fcb8a.zip
s3-kerberos: add check for prerequisite krb5/krb5.h header while checking for krb5/locate_plugin.h.
(Needed for new Heimdal versions). Guenther
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in9
1 files changed, 7 insertions, 2 deletions
diff --git a/source3/configure.in b/source3/configure.in
index aab8c01473..f624e0ef5d 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -3329,7 +3329,7 @@ if test x"$with_ads_support" != x"no"; then
# now check for krb5.h. Some systems have the libraries without the headers!
# note that this check is done here to allow for different kerberos
# include paths
- AC_CHECK_HEADERS(krb5.h)
+ AC_CHECK_HEADERS(krb5.h krb5/krb5.h)
if test x"$ac_cv_header_krb5_h" = x"no"; then
@@ -3350,7 +3350,12 @@ if test x"$with_ads_support" != x"no"; then
CPPFLAGS=$ac_save_CPPFLAGS
LDFLAGS=$ac_save_LDFLAGS
fi
- AC_CHECK_HEADERS(krb5/locate_plugin.h)
+ AC_CHECK_HEADERS([krb5/locate_plugin.h], [], [],
+[[#ifdef HAVE_KRB5_KRB5_H
+ #include <krb5/krb5.h>
+ #endif
+]])
+
if test x"$ac_cv_header_krb5_locate_plugin_h" = x"yes"; then
WINBIND_KRB5_LOCATOR="bin/winbind_krb5_locator.$SHLIBEXT"
if test x"$BLDSHARED" = x"true" ; then