summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorTim Potter <tpot@samba.org>2001-08-23 19:06:20 +0000
committerTim Potter <tpot@samba.org>2001-08-23 19:06:20 +0000
commitd1f53e404496dff10df7dc5e5b58ed676982c955 (patch)
treed43108f7f1a4fe99602b919032166e5935411413 /source3/configure.in
parent2f6486b55f05947205c380e071b16cd40af4d057 (diff)
downloadsamba-d1f53e404496dff10df7dc5e5b58ed676982c955.tar.gz
samba-d1f53e404496dff10df7dc5e5b58ed676982c955.tar.bz2
samba-d1f53e404496dff10df7dc5e5b58ed676982c955.zip
Fixed detection of CUPS. We need to check for the presence of the cups
header files as well as libcups. (This used to be commit 2dbb41a7b88e7fad63579111aaab4a1cd28c54d5)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in16
1 files changed, 15 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 88e2349d9a..85d73fa815 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -306,9 +306,23 @@ AC_CHECK_TYPE(offset_t,loff_t)
AC_CHECK_TYPE(ssize_t, int)
AC_CHECK_TYPE(wchar_t, unsigned short)
-# we need libcups for CUPS support...
+############################################
+# for cups support we need libcups, and a handful of header files
+
AC_CHECK_LIB(cups,httpConnect)
+# I wonder if there is a nicer way of doing this?
+
+if test x"$ac_cv_lib_cups_httpConnect" = x"yes"; then
+ AC_CHECK_HEADERS(cups/cups.h cups/language.h)
+ if x"$ac_cv_header_cups_cups_h" = x"yes"; then
+ if x"$ac_cv_header_cups_language_h" = x"yes"; then
+ AC_DEFINE(HAVE_CUPS)
+ fi
+ fi
+fi
+
+############################################
# we need libdl for PAM and the new VFS code
AC_CHECK_LIB(dl, dlopen, [LIBS="$LIBS -ldl";
AC_DEFINE(HAVE_LIBDL)])