summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJeff Layton <jlayton@samba.org>2009-06-30 15:03:13 -0400
committerJeff Layton <jlayton@redhat.com>2009-06-30 15:03:13 -0400
commitf7250144ed06b00fc1fbf1854d38483c427fad87 (patch)
tree036697dc0c1351ca97176e3fe33144f7486fd8bb /source3/configure.in
parent91a8cb851e1919a337310e2c699d8fcf76a55060 (diff)
downloadsamba-f7250144ed06b00fc1fbf1854d38483c427fad87.tar.gz
samba-f7250144ed06b00fc1fbf1854d38483c427fad87.tar.bz2
samba-f7250144ed06b00fc1fbf1854d38483c427fad87.zip
umount.cifs: don't build it by default
Now that the sanity checks for mount.cifs default to matching the behavior of /bin/mount, then there is virtually no need for umount.cifs. The only exception is when someone enables the loose setuid behavior in mount.cifs. If an unprivileged user mounts a share that isn't in /etc/fstab, then /bin/mount won't allow that user to unmount it. In that situation, umount.cifs will be necessary to allow unmounting the share. Signed-off-by: Jeff Layton <jlayton@samba.org> Acked-by: Steve French <smfrench@us.ibm.com>
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in43
1 files changed, 37 insertions, 6 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 97d1a8bbc7..027433611b 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -96,6 +96,9 @@ AC_SUBST(EXTRA_BIN_PROGS)
AC_SUBST(CIFSMOUNT_PROGS)
AC_SUBST(INSTALL_CIFSMOUNT)
AC_SUBST(UNINSTALL_CIFSMOUNT)
+AC_SUBST(CIFSUMOUNT_PROGS)
+AC_SUBST(INSTALL_CIFSUMOUNT)
+AC_SUBST(UNINSTALL_CIFSUMOUNT)
AC_SUBST(CIFSUPCALL_PROGS)
AC_SUBST(INSTALL_CIFSUPCALL)
AC_SUBST(UNINSTALL_CIFSUPCALL)
@@ -3985,9 +3988,9 @@ AC_ARG_WITH(automount,
CIFSMOUNT_PROGS=""
INSTALL_CIFSMOUNT=""
UNINSTALL_CIFSMOUNT=""
-AC_MSG_CHECKING(whether to build mount.cifs and umount.cifs)
+AC_MSG_CHECKING(whether to build mount.cifs)
AC_ARG_WITH(cifsmount,
-[AS_HELP_STRING([--with-cifsmount], [Include mount.cifs and umount.cifs (Linux only) support (default=yes)])],
+[AS_HELP_STRING([--with-cifsmount], [Include mount.cifs (Linux only) support (default=yes)])],
[ case "$withval" in
no)
AC_MSG_RESULT(no)
@@ -3996,8 +3999,8 @@ AC_ARG_WITH(cifsmount,
case "$host_os" in
*linux*)
AC_MSG_RESULT(yes)
- AC_DEFINE(WITH_CIFSMOUNT,1,[Whether to build mount.cifs and umount.cifs])
- CIFSMOUNT_PROGS="bin/mount.cifs bin/umount.cifs"
+ AC_DEFINE(WITH_CIFSMOUNT,1,[Whether to build mount.cifs])
+ CIFSMOUNT_PROGS="bin/mount.cifs"
INSTALL_CIFSMOUNT="installcifsmount"
UNINSTALL_CIFSMOUNT="uninstallcifsmount"
;;
@@ -4010,8 +4013,8 @@ AC_ARG_WITH(cifsmount,
[ case "$host_os" in
*linux*)
AC_MSG_RESULT(yes)
- AC_DEFINE(WITH_CIFSMOUNT,1,[Whether to build mount.cifs and umount.cifs])
- CIFSMOUNT_PROGS="bin/mount.cifs bin/umount.cifs"
+ AC_DEFINE(WITH_CIFSMOUNT,1,[Whether to build mount.cifs])
+ CIFSMOUNT_PROGS="bin/mount.cifs"
INSTALL_CIFSMOUNT="installcifsmount"
UNINSTALL_CIFSMOUNT="uninstallcifsmount"
;;
@@ -4021,6 +4024,34 @@ AC_ARG_WITH(cifsmount,
esac ]
)
+CIFSUMOUNT_PROGS=""
+INSTALL_CIFSUMOUNT=""
+UNINSTALL_CIFSUMOUNT=""
+AC_MSG_CHECKING(whether to build umount.cifs)
+AC_ARG_WITH(cifsumount,
+[AS_HELP_STRING([--with-cifsumount], [Include umount.cifs (Linux only) support (default=no)])],
+[ case "$withval" in
+ yes)
+ case "$host_os" in
+ *linux*)
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(WITH_CIFSUMOUNT,1,[Whether to build umount.cifs])
+ CIFSUMOUNT_PROGS="bin/umount.cifs"
+ INSTALL_CIFSUMOUNT="installcifsumount"
+ UNINSTALL_CIFSUMOUNT="uninstallcifsumount"
+ ;;
+ *)
+ AC_MSG_ERROR(not on a linux system!)
+ ;;
+ esac
+ ;;
+ *)
+ AC_MSG_RESULT(no)
+ ;;
+ esac ],
+ AC_MSG_RESULT(no)
+)
+
#################################################
# check for cifs.upcall support
AC_CHECK_HEADERS([keyutils.h], [HAVE_KEYUTILS_H=1], [HAVE_KEYUTILS_H=0])