summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorAndrew Tridgell <tridge@samba.org>2001-09-03 08:50:59 +0000
committerAndrew Tridgell <tridge@samba.org>2001-09-03 08:50:59 +0000
commitfd6ea431617d91c5f5c6b07cb26910f4900c1515 (patch)
treef079e0acc8629c45bf049f5bd58fe5b10e4b3d03 /source3/configure.in
parent95739423d0116074a16b7b1c6b389ca2bbe34c7c (diff)
downloadsamba-fd6ea431617d91c5f5c6b07cb26910f4900c1515.tar.gz
samba-fd6ea431617d91c5f5c6b07cb26910f4900c1515.tar.bz2
samba-fd6ea431617d91c5f5c6b07cb26910f4900c1515.zip
the next step in our error code handling change
- added WERROR for win32 error codes - added a configure test for immediate structures still lots to do, so its not enabled by default, but the main structure is there (This used to be commit 24f9ab683dec52587ee56717e821b49c0fa3d70f)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in33
1 files changed, 16 insertions, 17 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 44f4288a74..8154aabcc6 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -52,23 +52,6 @@ if test x"$samba_cv_volatile" = x"yes"; then
fi
-#################################################
-# set codepage directory location
-AC_ARG_WITH(codepagedir,
-[ --with-codepagedir=DIR Where to put codepage files (\$libdir/codepages)],
-[ case "$withval" in
- yes|no)
- #
- # Just in case anybody does it
- #
- AC_MSG_WARN([--with-codepagedir called without argument - will use default])
- ;;
- * )
- codepagedir="$withval"
- ;;
- esac])
-
-
AC_CANONICAL_SYSTEM
dnl Add #include for broken IRIX header files
@@ -327,6 +310,22 @@ fi
AC_CHECK_LIB(dl, dlopen, [LIBS="$LIBS -ldl";
AC_DEFINE(HAVE_LIBDL)])
+
+############################################
+# check if the compiler can do immediate structures
+AC_CACHE_CHECK([for immediate structures],samba_cv_immediate_structures, [
+ AC_TRY_COMPILE([
+#include <stdio.h>],
+[
+ #define X_FOOBAR(x) ((FOOBAR) { x })
+ typedef struct {unsigned x;} FOOBAR;
+ FOOBAR f = X_FOOBAR(1);
+],
+ samba_cv_immediate_structures=yes,samba_cv_immediate_structures=no)])
+if test x"$samba_cv_immediate_structures" = x"yes"; then
+ AC_DEFINE(HAVE_IMMEDIATE_STRUCTURES)
+fi
+
############################################
# check for unix domain sockets
AC_CACHE_CHECK([for unix domain sockets],samba_cv_unixsocket, [