summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJames Peach <jpeach@samba.org>2006-03-22 23:49:09 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 11:15:42 -0500
commit40d0707827ee154bcb03013abe6f72f1026a70c9 (patch)
treeb465d32e79fc65a682aa55dd96e4a665109bfc15 /source3/configure.in
parente836508704dd964e22e8bfc0f8e9ec520a2c94f2 (diff)
downloadsamba-40d0707827ee154bcb03013abe6f72f1026a70c9.tar.gz
samba-40d0707827ee154bcb03013abe6f72f1026a70c9.tar.bz2
samba-40d0707827ee154bcb03013abe6f72f1026a70c9.zip
r14668: Set the FILE_STATUS_OFFLINE bit by observing the events a DMAPI-based
HSM is interested in. Tested on both IRIX and SLES9. (This used to be commit 514a767c57f8194547e5b708ad2573ab9a0719c6)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in17
1 files changed, 15 insertions, 2 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 6063ecf0f3..f3fa91e3b4 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -829,6 +829,7 @@ AC_CHECK_HEADERS(sys/termio.h sys/statfs.h sys/dustat.h sys/statvfs.h stdarg.h s
AC_CHECK_HEADERS(sys/sysmacros.h security/_pam_macros.h dlfcn.h)
AC_CHECK_HEADERS(sys/syslog.h syslog.h execinfo.h)
AC_CHECK_HEADERS(langinfo.h locale.h)
+AC_CHECK_HEADERS(sys/dmi.h xfs/dmapi.h)
AC_CHECK_HEADERS(rpcsvc/yp_prot.h,,,[[
#if HAVE_RPC_RPC_H
@@ -2337,6 +2338,17 @@ if test x"$samba_cv_HAVE_LIBFAM" = x"yes" ; then
[])
fi
+#################################################
+# Check for DMAPI interfaces in libdm.
+
+AC_CHECK_LIB(dm, dm_get_eventlist,
+ [samba_cv_HAVE_LIBDM=yes; samba_dmapi_libs="-ldm"],
+ [samba_cv_HAVE_LIBDM=no])
+
+if test x"$samba_cv_HAVE_LIBDM" = x"yes" ; then
+ AC_DEFINE(HAVE_LIBDM, 1, [Whether libdm is available])
+fi
+
AC_CACHE_CHECK([for kernel share modes],samba_cv_HAVE_KERNEL_SHARE_MODES,[
AC_TRY_RUN([
#include <sys/types.h>
@@ -5423,8 +5435,9 @@ AC_TRY_RUN([#include "${srcdir-.}/tests/summary.c"],
builddir=`pwd`
AC_SUBST(builddir)
-# Stuff the FAM libraries at the end of the smbd link path (if we have them).
-SMBD_LIBS="$samba_fam_libs"
+# Stuff the smbd-only libraries at the end of the smbd link
+# path (if we have them).
+SMBD_LIBS="$samba_fam_libs $samba_dmapi_libs"
AC_SUBST(SMBD_LIBS)
dnl Remove -L/usr/lib/? from LDFLAGS and LIBS