summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorIgor Mammedov <niallain@gmail.com>2007-12-05 18:21:29 +0300
committerSimo Sorce <idra@samba.org>2007-12-05 14:33:21 -0500
commit44a59c41cfee612191315c91ea195e28696f1d06 (patch)
tree0bd765a66c2aafe8bbea9321830dbfc0c4825e43 /source3/configure.in
parent5d227007829f739ac444ab19602e37cfe6dbe9b4 (diff)
downloadsamba-44a59c41cfee612191315c91ea195e28696f1d06.tar.gz
samba-44a59c41cfee612191315c91ea195e28696f1d06.tar.bz2
samba-44a59c41cfee612191315c91ea195e28696f1d06.zip
* Adds support for cifs.spnego helper into configure and Makefile.in
* Added checks for spnego prereq keyutils.h and kerberos in configure.in Signed-off-by: Igor Mammedov <niallain@gmail.com> (This used to be commit f802db70b8675df43fba892986203bbeac2d02f8)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in42
1 files changed, 42 insertions, 0 deletions
diff --git a/source3/configure.in b/source3/configure.in
index 8a945a295d..4eea3313f9 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -343,6 +343,9 @@ AC_SUBST(SMBMOUNT_PROGS)
AC_SUBST(CIFSMOUNT_PROGS)
AC_SUBST(INSTALL_CIFSMOUNT)
AC_SUBST(UNINSTALL_CIFSMOUNT)
+AC_SUBST(CIFSSPNEGO_PROGS)
+AC_SUBST(INSTALL_CIFSSPNEGO)
+AC_SUBST(UNINSTALL_CIFSSPNEGO)
AC_SUBST(EXTRA_SBIN_PROGS)
AC_SUBST(EXTRA_ALL_TARGETS)
AC_SUBST(CONFIG_LIBS)
@@ -4457,6 +4460,45 @@ AC_ARG_WITH(cifsmount,
esac ]
)
+#################################################
+# check for cifs.spnego support
+AC_CHECK_HEADERS([keyutils.h], [HAVE_KEYUTILS_H=1], [HAVE_KEYUTILS_H=0])
+CIFSSPNEGO_PROGS=""
+INSTALL_CIFSSPNEGO=""
+UNINSTALL_CIFSSPNEGO=""
+AC_MSG_CHECKING(whether to build cifs.spnego)
+AC_ARG_WITH(cifsspnego,
+[ --with-cifsspnego Include cifs.spnego (Linux only) support (default=no)],
+[ case "$withval" in
+ no)
+ AC_MSG_RESULT(no)
+ ;;
+ *)
+ case "$host_os" in
+ *linux*)
+ if test x"$use_ads" != x"yes"; then
+ AC_MSG_ERROR(ADS support should be enabled for building cifs.spnego)
+ elif test x"$HAVE_KEYUTILS_H" != "x1"; then
+ AC_MSG_ERROR(keyutils package is required for cifs.spnego)
+ else
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(WITH_CIFSSPNEGO,1,[whether to build cifs.spnego])
+ CIFSSPNEGO_PROGS="bin/cifs.spnego"
+ INSTALL_CIFSSPNEGO="installcifsspnego"
+ UNINSTALL_CIFSSPNEGO="uninstallcifsspnego"
+ fi
+ ;;
+ *)
+ AC_MSG_ERROR(not on a linux system!)
+ ;;
+ esac
+ ;;
+ esac ],
+[
+ AC_MSG_RESULT(no)
+ ]
+)
+
#################################################
# Check for a PAM clear-text auth, accounts, password