summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@samba.org>2007-09-28 22:16:14 +0000
committerGerald (Jerry) Carter <jerry@samba.org>2007-10-10 12:31:03 -0500
commit679ef7b6babef0666749bea1d3b722786ce928d9 (patch)
treee042b4b5de1ea41807c7dd6e4b696538c08283de /source3/configure.in
parent5221ebb299081da6a806362212c6a8ceb9cc70a8 (diff)
downloadsamba-679ef7b6babef0666749bea1d3b722786ce928d9.tar.gz
samba-679ef7b6babef0666749bea1d3b722786ce928d9.tar.bz2
samba-679ef7b6babef0666749bea1d3b722786ce928d9.zip
r25415: Merge the 3.2-perltest branch that switches Samba 3.2 to use Samba 4's selftest code. See the mailing list for details.
(This used to be commit bdc831ddb3a860676c36bbd89e6f748946df68a1)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in20
1 files changed, 11 insertions, 9 deletions
diff --git a/source3/configure.in b/source3/configure.in
index df4d040b0f..5762746c40 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -373,7 +373,7 @@ AC_SUBST(SWAT_INSTALL_TARGETS)
#################################################
# set prefix for 'make test'
-selftest_prefix="./"
+selftest_prefix="./st"
AC_SUBST(selftest_prefix)
AC_ARG_WITH(selftest-prefix,
[ --with-selftest-prefix=DIR The prefix where make test will be runned ($selftest_prefix)],
@@ -418,18 +418,18 @@ fi
#################################################
# set path of samba4's smbtorture
-smbtorture4_path=""
-AC_SUBST(smbtorture4_path)
-AC_ARG_WITH(smbtorture4_path,
-[ --with-smbtorture4-path=PATH The path to a samba4 smbtorture for make test (none)],
+samba4srcdir=""
+AC_SUBST(samba4srcdir)
+AC_ARG_WITH(samba4srcdir,
+[ --with-samba4srcdir=PATH The path to a samba4 source directorhy for make test (none)],
[ case "$withval" in
yes|no)
- AC_MSG_ERROR([--with-smbtorture4-path should take a path])
+ AC_MSG_ERROR([--with-samba4srcdir should take a path])
;;
* )
- smbtorture4_path="$withval"
- if test -z "$smbtorture4_path" -a ! -f $smbtorture4_path; then
- AC_MSG_ERROR(['$smbtorture_path' does not exist!])
+ samba4srcdir="$withval"
+ if test -z "$samba4srcdir" -a ! -f $samba4srcdir; then
+ AC_MSG_ERROR(['$samba4srcdir' does not exist!])
fi
;;
esac
@@ -6420,7 +6420,9 @@ if test x"$RUN_FROM_BUILD_FARM" = x"yes"; then
AC_DEFINE(ENABLE_BUILD_FARM_HACKS, 1, [Defined if running in the build farm])
else
AC_MSG_RESULT(no)
+ SELFTEST_ARGS="$SELFTEST_ARGS --skip=samba3-skip-nobuildfarm"
fi
+AC_SUBST(SELFTEST_ARGS)
#################################################
# check for bad librt/libpthread interactions