summaryrefslogtreecommitdiff
path: root/source3/configure.in
diff options
context:
space:
mode:
authorTim Potter <tpot@samba.org>2000-02-03 05:55:11 +0000
committerTim Potter <tpot@samba.org>2000-02-03 05:55:11 +0000
commit79601327cb9840153ccf641085eba19a1e32e143 (patch)
treef60785ac2b7807029c78010dfc5ee8b2430fbf03 /source3/configure.in
parentbc48e6d9e95ceffbc4eea8357a169c740b2844b1 (diff)
downloadsamba-79601327cb9840153ccf641085eba19a1e32e143.tar.gz
samba-79601327cb9840153ccf641085eba19a1e32e143.tar.bz2
samba-79601327cb9840153ccf641085eba19a1e32e143.zip
Backed out -rdynamic linker option. It seems to be GNU ld specific.
Need a platform independant way of exporting symbols for dlopen(). Perhaps this is only needed for certain platforms anyway... (This used to be commit 8b26be1e82d329c9ea8a1d6a71e5e9f440eb93ac)
Diffstat (limited to 'source3/configure.in')
-rw-r--r--source3/configure.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/source3/configure.in b/source3/configure.in
index c2d57f566b..9c55e86a26 100644
--- a/source3/configure.in
+++ b/source3/configure.in
@@ -228,7 +228,8 @@ AC_CHECK_TYPE(wchar_t, unsigned short)
AC_CHECK_LIB(cups,httpConnect)
# we need libdl for PAM and the new VFS code
-AC_CHECK_LIB(dl,main, [LDFLAGS="$LDFLAGS -rdynamic"; LIBS="$LIBS -ldl"])
+AC_CHECK_LIB(dl, dlopen, [LIBS="$LIBS -ldl";
+ AC_DEFINE(HAVE_LIBDL)])
AC_CACHE_CHECK([for sig_atomic_t type],samba_cv_sig_atomic_t, [
AC_TRY_COMPILE([